From 65040caed33a678e99caa691a99c5ad9abf19cee Mon Sep 17 00:00:00 2001
From: Evan Broder <broder@mit.edu>
Date: Tue, 27 Jan 2009 01:36:50 -0500
Subject: [PATCH] Turn off transmission segmentation offloading instead of tx
 checksum offloading

svn path=/trunk/packages/invirt-autoinstaller/; revision=2019
---
 .../lib/xen-tools/debian.d/98-fix-eth-checksums    |    5 ++++-
 debian/changelog                                   |    5 ++++-
 2 files changed, 8 insertions(+), 2 deletions(-)

diff --git a/common/usr/lib/xen-tools/debian.d/98-fix-eth-checksums b/common/usr/lib/xen-tools/debian.d/98-fix-eth-checksums
index 94d888e..dcd4129 100755
--- a/common/usr/lib/xen-tools/debian.d/98-fix-eth-checksums
+++ b/common/usr/lib/xen-tools/debian.d/98-fix-eth-checksums
@@ -19,7 +19,10 @@ logMessage Script $0 starting
 # To avoid UDP checksum problems.
 installDebianPackage ${prefix} ethtool
 
-sed -i'' -e 's/\(\s*\)# post-up/\1post-up/' ${prefix}/etc/network/interfaces
+if ! sed -i -e 's/^\(\s*\)#\s*post-up\s\+ethtool/\1post-up ethtool -K eth0 tso off\n\0/' ${prefix}/etc/network/interfaces; then
+    echo "ERROR: unable to disable network segmentation offloading"
+    exit 1
+fi
 
 #
 # Log our finish
diff --git a/debian/changelog b/debian/changelog
index cd6fcac..2dccb5c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,11 @@
 invirt-autoinstaller (0.0.7) unstable; urgency=low
 
   * Add a script to update the autoinstaller disk from a host.
+  * Use a more stringent regexp and fail loudly if the match fails.
+  * Turn off transmission segmentation offloading instead of tx checksum
+    offloading
 
- -- Evan Broder <broder@mit.edu>  Mon, 26 Jan 2009 19:47:47 -0500
+ -- Evan Broder <broder@mit.edu>  Mon, 26 Jan 2009 20:57:09 -0500
 
 invirt-autoinstaller (0.0.6) unstable; urgency=low
 
-- 
1.7.9.5