Made the sshd divert work properly
[invirt/packages/invirt-base.git] / debian / invirt-base.postinst
index a2ae96f..21cd207 100755 (executable)
@@ -1,5 +1,5 @@
 #!/bin/sh
-# postinst script for #PACKAGE#
+# postinst script for invirt-base.postinst
 #
 # see: dh_installdeb(1)
 
@@ -20,6 +20,12 @@ set -e
 
 case "$1" in
     configure)
+       # Stolen from debathena
+       if hash invoke-rc.d; then
+            invoke-rc.d ssh restart
+        else
+            /etc/init.d/ssh restart
+        fi
     ;;
 
     abort-upgrade|abort-remove|abort-deconfigure)