From 9b5b9aa21dd2b255d9d4464581b438f67348999e Mon Sep 17 00:00:00 2001
From: Greg Price <price@mit.edu>
Date: Sun, 28 Dec 2008 02:56:22 -0500
Subject: [PATCH] document config-init.sh better

svn path=/trunk/packages/invirt-base/; revision=1929
---
 debian/changelog              |    4 ++--
 files/lib/init/config-init.sh |   16 +++++++++++-----
 2 files changed, 13 insertions(+), 7 deletions(-)

diff --git a/debian/changelog b/debian/changelog
index c187e35..c433d61 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,9 @@
 invirt-base (0.0.18) unstable; urgency=low
 
   * run_parts_list: fix unclear docstring
-  * config-init.sh: degrade to non-bash gracefully
+  * config-init.sh: degrade to non-bash gracefully, document better
 
- -- Greg Price <price@mit.edu>  Sun, 28 Dec 2008 01:00:07 -0500
+ -- Greg Price <price@mit.edu>  Sun, 28 Dec 2008 02:46:33 -0500
 
 invirt-base (0.0.17) unstable; urgency=low
 
diff --git a/files/lib/init/config-init.sh b/files/lib/init/config-init.sh
index d9d1f76..33ea582 100644
--- a/files/lib/init/config-init.sh
+++ b/files/lib/init/config-init.sh
@@ -1,12 +1,18 @@
 # For a package which only configures another, "parent" package.
 #
-# Global variable PARENTPACKAGE names parent; unset for no parent,
-# array for (zero or one or) many parents.
+# Usage:
+#   PACKAGE=short-name
+#   GEN_FILES=(files to generate)
+#   PARENTPACKAGE=(parent-package another-parent-package)
+#   . /lib/init/config-init.sh
+#   config_init "$1"
 #
-# Global variable PACKAGE names this package, for log message.
+# PACKAGE       - name to appear in log message
+# GEN_FILES     - files to be generated with gen-files.sh
+# PARENTPACKAGE - packages to receive start, etc, commands passed through
 #
-# If BASH_VERSION is null or unset, accepts only one parent in
-# PARENTPACKAGE, or empty for zero.
+# Global variables GEN_FILES, PARENTPACKAGE may be unset for zero
+# values, or scalars for one.  If run under sh, they cannot be arrays.
 
 . /lib/init/vars.sh
 . /lib/lsb/init-functions
-- 
1.7.9.5