From c475143b2b047a068fe5615dcd6c961b98c2b36d Mon Sep 17 00:00:00 2001
From: Greg Price <price@mit.edu>
Date: Sun, 27 Jul 2008 18:38:37 -0400
Subject: [PATCH] begin a Python package 'invirt'

svn path=/trunk/packages/sipb-xen-base/; revision=725
---
 debian/changelog                                   |    6 ++++++
 debian/rules                                       |    5 ++++-
 .../sipb-xen-base/invirt/__init__.py               |   21 ++++++++++++++++++++
 3 files changed, 31 insertions(+), 1 deletion(-)
 create mode 100644 files/usr/share/python-support/sipb-xen-base/invirt/__init__.py

diff --git a/debian/changelog b/debian/changelog
index f155e9c..dd2ee8a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+sipb-xen-base (8.4) unstable; urgency=low
+
+  * begin a Python package 'invirt'
+
+ -- Greg Price <price@mit.edu>  Sun, 27 Jul 2008 18:37:43 -0400
+
 sipb-xen-base (8.3) unstable; urgency=low
 
   * add invirt-reload to regenerate and reload configs
diff --git a/debian/rules b/debian/rules
index 18d5e2c..6a0e7d7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,7 @@
 #!/usr/bin/make -f
 
-
 include /usr/share/cdbs/1/rules/debhelper.mk
+
+# do we, should we, care between pysupport and pycentral?
+binary-install/sipb-xen-base::
+	dh_pysupport -psipb-xen-base
diff --git a/files/usr/share/python-support/sipb-xen-base/invirt/__init__.py b/files/usr/share/python-support/sipb-xen-base/invirt/__init__.py
new file mode 100644
index 0000000..18d44f9
--- /dev/null
+++ b/files/usr/share/python-support/sipb-xen-base/invirt/__init__.py
@@ -0,0 +1,21 @@
+'''Invirt - a virtualization management system
+
+Invirt was developed at the Student Information Processing Board of
+the Massachusetts Institute of Technology.  See http://xvm.mit.edu/.
+
+Invirt is free software available under the GNU GPL, version 2 or later.
+Consult the source files for details.
+'''
+
+# Invirt is free software: you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation, either version 2 of the License, or (at your
+# option) any later version.
+
+# Invirt is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License
+# for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Invirt.  If not, see <http://www.gnu.org/licenses/>.
-- 
1.7.9.5