From 0237b992fa06293ed75f7fa154425a9d3b922c96 Mon Sep 17 00:00:00 2001
From: Evan Broder <broder@mit.edu>
Date: Thu, 6 Nov 2008 18:57:41 -0500
Subject: [PATCH] In invirt-update-conserver, specify the full path to
 invoke-rc.d for when it's run as a cron job

svn path=/trunk/packages/invirt-console-host/; revision=1539
---
 debian/changelog                       |    7 +++++++
 files/usr/sbin/invirt-update-conserver |    2 +-
 2 files changed, 8 insertions(+), 1 deletion(-)

diff --git a/debian/changelog b/debian/changelog
index 88af8e3..d263659 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+invirt-console-host (0.0.8) unstable; urgency=low
+
+  * Specify a full path to invoke-rc.d for when this gets run as a cron
+    job
+
+ -- Evan Broder <broder@mit.edu>  Thu, 06 Nov 2008 18:57:02 -0500
+
 invirt-console-host (0.0.7) unstable; urgency=low
 
   * Use invoke-rc.d instead of calling init scripts directly
diff --git a/files/usr/sbin/invirt-update-conserver b/files/usr/sbin/invirt-update-conserver
index b9aba8c..9a7fd3c 100755
--- a/files/usr/sbin/invirt-update-conserver
+++ b/files/usr/sbin/invirt-update-conserver
@@ -13,7 +13,7 @@ def live_vms():
     return vms
 
 def reload_conserver():
-    p = subprocess.Popen(['invoke-rc.d', 'conserver-server', 'reload'], stdout=subprocess.PIPE)
+    p = subprocess.Popen(['/usr/sbin/invoke-rc.d', 'conserver-server', 'reload'], stdout=subprocess.PIPE)
     p.wait()
 
 if __name__ == '__main__':
-- 
1.7.9.5