From 5be442f9fa4174265ccfb5b3bd67ffb4e71afc12 Mon Sep 17 00:00:00 2001
From: Evan Broder <broder@mit.edu>
Date: Sun, 2 Nov 2008 17:09:14 -0500
Subject: [PATCH] Apparently remctl scripts run without a PATH

svn path=/trunk/packages/invirt-console-server/; revision=1512
---
 debian/changelog                     |    6 ++++++
 files/usr/sbin/invirt-console-update |    2 +-
 2 files changed, 7 insertions(+), 1 deletion(-)

diff --git a/debian/changelog b/debian/changelog
index 310d845..c974244 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+invirt-console-server (0.0.7) unstable; urgency=low
+
+  * Apparently remctl scripts run without a PATH
+
+ -- Evan Broder <broder@mit.edu>  Sun, 02 Nov 2008 17:08:35 -0500
+
 invirt-console-server (0.0.6) unstable; urgency=low
 
   * Use invoke-rc.d instead of calling init scripts directly
diff --git a/files/usr/sbin/invirt-console-update b/files/usr/sbin/invirt-console-update
index a6716d7..e24a3ce 100755
--- a/files/usr/sbin/invirt-console-update
+++ b/files/usr/sbin/invirt-console-update
@@ -9,7 +9,7 @@ def main(args):
   f = file('/etc/conserver/conf.d/'+hostname, 'w')
   f.write(contents)
   f.close()
-  p = subprocess.Popen(['invoke-rc.d', 'conserver-server', 'reload'],
+  p = subprocess.Popen(['/usr/sbin/invoke-rc.d', 'conserver-server', 'reload'],
                        stdout=subprocess.PIPE)
   p.wait()
   return 0
-- 
1.7.9.5