#!/bin/sh
# postinst script for invirt-database-server
#
# see: dh_installdeb(1)

set -e

# summary of how this script can be called:
#        * <postinst> `configure' <most-recently-configured-version>
#        * <old-postinst> `abort-upgrade' <new version>
#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
#          <new-version>
#        * <postinst> `abort-remove'
#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
#          <failed-install-package> <version> `removing'
#          <conflicting-package> <version>
# for details, see http://www.debian.org/doc/debian-policy/ or
# the debian-policy package

# dh_installdeb will replace this with shell code automatically
# generated by other debhelper scripts.
# Note that by moving this above our generated code we could run into significant problems
# if we happened to start a daemon, and use debconf
# We move this up here because we need the diversion of postgresql.conf to happen before we create tables

#DEBHELPER#


case "$1" in
    configure)
        #Don't create users on upgrade
        if [ -z "$2" ]; then
            # Don't fail if the user/database already exists
            su postgres -c 'createuser invirt -S -d -R'    || true
            su postgres -c 'createdb invirt -O invirt'   || true
            adduser --system invirt
        fi
	invoke-rc.d postgresql-8.3 restart
        su invirt -s /bin/sh -c 'invirt-database-tables create'
    ;;

    abort-upgrade|abort-remove|abort-deconfigure)
    ;;

    *)
        echo "postinst called with unknown argument \`$1'" >&2
        exit 1
    ;;
esac

exit 0