Catch calls to restart Postgres and translate them into a sequential
[invirt/packages/invirt-database.git] / debian / sipb-xen-database-server.postinst
index 9d14353..cbc1061 100644 (file)
@@ -17,14 +17,26 @@ set -e
 # for details, see http://www.debian.org/doc/debian-policy/ or
 # the debian-policy package
 
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+# Note that by moving this above our generated code we could run into significant problems
+# if we happened to start a daemon, and use debconf
+# We move this up here because we need the diversion of postgresql.conf to happen before we create tables
+
+#DEBHELPER#
+
 
 case "$1" in
     configure)
-        # Don't fail if the user/database already exists
-        su postgres -c 'createuser sipb-xen -S -d -R'    || true
-        su postgres -c 'createdb sipb_xen -O sipb-xen'   || true
-        adduser --system sipb-xen
-
+        #Don't create users on upgrade
+        if [ -z "$2" ]; then
+            # Don't fail if the user/database already exists
+            su postgres -c 'createuser sipb-xen -S -d -R'    || true
+            su postgres -c 'createdb sipb_xen -O sipb-xen'   || true
+            adduser --system sipb-xen
+        fi
+       mako-render /etc/postgresql/8.3/main/pg_hba.conf.mako >/etc/postgresql/8.3/main/pg_hba.conf
+       /etc/init.d/postgresql-8.3 restart
         su sipb-xen -s /bin/sh -c 'sipb-xen-database-tables create'
     ;;
 
@@ -37,11 +49,6 @@ case "$1" in
     ;;
 esac
 
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
-#DEBHELPER#
-
 exit 0