sipb-xen-database-common -> invirt-database
[invirt/packages/invirt-database.git] / debian / sipb-xen-database-server.postinst
diff --git a/debian/sipb-xen-database-server.postinst b/debian/sipb-xen-database-server.postinst
deleted file mode 100644 (file)
index cbc1061..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-#!/bin/sh
-# postinst script for #PACKAGE#
-#
-# see: dh_installdeb(1)
-
-set -e
-
-# summary of how this script can be called:
-#        * <postinst> `configure' <most-recently-configured-version>
-#        * <old-postinst> `abort-upgrade' <new version>
-#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
-#          <new-version>
-#        * <postinst> `abort-remove'
-#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
-#          <failed-install-package> <version> `removing'
-#          <conflicting-package> <version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-# Note that by moving this above our generated code we could run into significant problems
-# if we happened to start a daemon, and use debconf
-# We move this up here because we need the diversion of postgresql.conf to happen before we create tables
-
-#DEBHELPER#
-
-
-case "$1" in
-    configure)
-        #Don't create users on upgrade
-        if [ -z "$2" ]; then
-            # Don't fail if the user/database already exists
-            su postgres -c 'createuser sipb-xen -S -d -R'    || true
-            su postgres -c 'createdb sipb_xen -O sipb-xen'   || true
-            adduser --system sipb-xen
-        fi
-       mako-render /etc/postgresql/8.3/main/pg_hba.conf.mako >/etc/postgresql/8.3/main/pg_hba.conf
-       /etc/init.d/postgresql-8.3 restart
-        su sipb-xen -s /bin/sh -c 'sipb-xen-database-tables create'
-    ;;
-
-    abort-upgrade|abort-remove|abort-deconfigure)
-    ;;
-
-    *)
-        echo "postinst called with unknown argument \`$1'" >&2
-        exit 1
-    ;;
-esac
-
-exit 0
-
-