invirt-quota: fix imports EIBTI-style
[invirt/packages/invirt-database.git] / debian / changelog
index 21d5a6a..d187a03 100644 (file)
@@ -1,3 +1,22 @@
+invirt-database (0.1.8) unstable; urgency=low
+
+  [Peter Iannucci]
+  * Added Record superclass for models, handling __repr__ consistently.
+
+  [Greg Price]
+  invirt.database.record, .owner:
+  * use self.c rather than self.__dict__ for SQLAlchemy fields
+  * make Record._ignore, Owner.get* classmethods
+  * fold FormattableRecord, NullableRecord into Record
+  * shorten types in lists to __name__
+  
+  invirt-quota:
+  * refactor code that sets values
+  * print full help on no arguments
+  * make EIBTI imports
+
+ -- Greg Price <price@mit.edu>  Fri, 27 Feb 2009 02:16:28 -0500
+
 invirt-database (0.1.7) unstable; urgency=low
 
   * Disk quotas are measured in gibibytes.