Adding postini and prerm scripts for sipb-xen-database-server
[invirt/packages/invirt-database.git] / debian / sipb-xen-database-server.postinst
diff --git a/debian/sipb-xen-database-server.postinst b/debian/sipb-xen-database-server.postinst
new file mode 100644 (file)
index 0000000..ef5e29e
--- /dev/null
@@ -0,0 +1,63 @@
+#!/bin/sh
+# postinst script for #PACKAGE#
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+#        * <postinst> `configure' <most-recently-configured-version>
+#        * <old-postinst> `abort-upgrade' <new version>
+#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+#          <new-version>
+#        * <postinst> `abort-remove'
+#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+#          <failed-install-package> <version> `removing'
+#          <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+    configure)
+        # Don't fail if the user/database already exists
+        su postgres -c 'createuser sipb-xen -S -d -R'    || true
+        su postgres -c 'createdb sipb_xen -O sipb-xen'   || true
+        PG_HBA=/etc/postgresql/8.1/main/pg_hba.conf
+        perl -ni -e 'print unless /^# ===BEGIN ADDED BY sipb-xen-dabase server$/ ..
+                                  /^# ===END ADDED BY sipb-xen-dabase server$/' \
+                                  "$PG_HBA"
+        cat<<EOF >> "$PG_HBA"
+# ===BEGIN ADDED BY sipb-xen-dabase server
+# DO NOT EDIT
+host    sipb_xen    sipb-xen    127.0.0.1/32          trust
+local   sipb_xen    sipb-xen                          trust
+# ===END ADDED BY sipb-xen-dabase server
+EOF
+
+        if hash invoke-rc.d; then
+            invoke-rc.d postgresql-8.1 restart
+        else
+            /etc/init.d/postgresql-8.1 restart
+        fi
+
+        sipb-xen-database-tables create
+    ;;
+
+    abort-upgrade|abort-remove|abort-deconfigure)
+    ;;
+
+    *)
+        echo "postinst called with unknown argument \`$1'" >&2
+        exit 1
+    ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+