A new version with less broken init scripts
[invirt/packages/invirt-database.git] / debian / sipb-xen-database-server.postinst
index ef5e29e..9d14353 100644 (file)
@@ -23,25 +23,9 @@ case "$1" in
         # Don't fail if the user/database already exists
         su postgres -c 'createuser sipb-xen -S -d -R'    || true
         su postgres -c 'createdb sipb_xen -O sipb-xen'   || true
-        PG_HBA=/etc/postgresql/8.1/main/pg_hba.conf
-        perl -ni -e 'print unless /^# ===BEGIN ADDED BY sipb-xen-dabase server$/ ..
-                                  /^# ===END ADDED BY sipb-xen-dabase server$/' \
-                                  "$PG_HBA"
-        cat<<EOF >> "$PG_HBA"
-# ===BEGIN ADDED BY sipb-xen-dabase server
-# DO NOT EDIT
-host    sipb_xen    sipb-xen    127.0.0.1/32          trust
-local   sipb_xen    sipb-xen                          trust
-# ===END ADDED BY sipb-xen-dabase server
-EOF
-
-        if hash invoke-rc.d; then
-            invoke-rc.d postgresql-8.1 restart
-        else
-            /etc/init.d/postgresql-8.1 restart
-        fi
-
-        sipb-xen-database-tables create
+        adduser --system sipb-xen
+
+        su sipb-xen -s /bin/sh -c 'sipb-xen-database-tables create'
     ;;
 
     abort-upgrade|abort-remove|abort-deconfigure)