Add "reusable" column for nics, to avoid reusing addresses that are special in some...
[invirt/packages/invirt-database.git] / debian / changelog
index 24d4a52..2ce6710 100644 (file)
@@ -1,9 +1,64 @@
+invirt-database (0.1.8) unstable; urgency=low
+
+  [Peter Iannucci]
+  * Added Record superclass for models, handling __repr__ consistently.
+
+  [Greg Price]
+  invirt.database.record, .owner:
+  * use self.c rather than self.__dict__ for SQLAlchemy fields
+  * make Record._ignore, Owner.get* classmethods
+  * fold FormattableRecord, NullableRecord into Record
+  * shorten types in lists to __name__
+  
+  invirt-quota:
+  * refactor code that sets values
+  * print full help on no arguments
+
+  all:
+  * make EIBTI imports
+
+  [ Quentin Smith ]
+  * Add "reusable" column for nics, to avoid reusing addresses that are
+    special in some way.
+
+ -- Quentin Smith <quentin@mit.edu>  Fri, 27 Feb 2009 11:51:39 -0500
+
+invirt-database (0.1.7) unstable; urgency=low
+
+  * Disk quotas are measured in gibibytes.
+  * Rename invirt-setquotas to invirt-quota.
+  * Be explicit about units in invirt-quota.
+
+ -- Evan Broder <broder@mit.edu>  Tue, 17 Feb 2009 04:29:20 -0500
+
+invirt-database (0.1.6) unstable; urgency=low
+
+  * Move invirt-setquotas into this package.
+  * Don't explicitly initialize the values for each quota when creating a
+    new Owner object.
+
+ -- Evan Broder <broder@mit.edu>  Tue, 17 Feb 2009 03:44:20 -0500
+
+invirt-database (0.1.5) unstable; urgency=low
+
+  * Make the default values on the owners table explicit
+    (Note: This is a NOOP, since a nullable field with no otherwise
+    specified default defaults to NULL)
+
+ -- Evan Broder <broder@mit.edu>  Tue, 17 Feb 2009 03:36:47 -0500
+
+invirt-database (0.1.4) unstable; urgency=low
+
+  * minor bug fix
+
+ -- Peter A. Iannucci <iannucci@mit.edu>  Tue, 17 Feb 2009 02:59:14 -0500
+
 invirt-database (0.1.3) unstable; urgency=low
 
-  * Added owner table with ram quotas.
+  * Added owner table to database with ram, disk, and VM quotas
   * Refactored Owner class into separate sourcefile
 
- -- Peter A. Iannucci <iannucci@mit.edu>  Mon, 16 Feb 2009 23:49:39 -0500
+ -- Peter A. Iannucci <iannucci@mit.edu>  Tue, 17 Feb 2009 01:31:53 -0500
 
 invirt-database (0.1.2) unstable; urgency=low