From 98a10bc318400fb93d0d9da10a2e128c7f46578e Mon Sep 17 00:00:00 2001
From: Evan Broder <broder@mit.edu>
Date: Tue, 17 Feb 2009 04:29:48 -0500
Subject: [PATCH] Be explicit about units in invirt-setquota.

svn path=/trunk/packages/invirt-database/; revision=2158
---
 debian/changelog         |    5 +++--
 python/database/owner.py |    4 ++--
 2 files changed, 5 insertions(+), 4 deletions(-)

diff --git a/debian/changelog b/debian/changelog
index 40bc3fb..21d5a6a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,10 @@
 invirt-database (0.1.7) unstable; urgency=low
 
-  * Disk quotas are measured in gigabytes.
+  * Disk quotas are measured in gibibytes.
   * Rename invirt-setquotas to invirt-quota.
+  * Be explicit about units in invirt-quota.
 
- -- Evan Broder <broder@mit.edu>  Tue, 17 Feb 2009 04:16:33 -0500
+ -- Evan Broder <broder@mit.edu>  Tue, 17 Feb 2009 04:29:20 -0500
 
 invirt-database (0.1.6) unstable; urgency=low
 
diff --git a/python/database/owner.py b/python/database/owner.py
index 196bd85..504a70f 100755
--- a/python/database/owner.py
+++ b/python/database/owner.py
@@ -25,8 +25,8 @@ class Owner(object):
             e = MAX_VMS_TOTAL
         if not f:
             f = MAX_VMS_ACTIVE
-        return """<Owner %s: ram_quota_total=%s MB ram_quota_single=%s MB
-disk_quota_total=%s GB disk_quota_single=%s GB
+        return """<Owner %s: ram_quota_total=%s MiB ram_quota_single=%s MiB
+disk_quota_total=%s GiB disk_quota_single=%s GiB
 vms_quota_total=%s vms_quota_active=%s >""" % (self.owner_id, a,b,c,d,e,f)
     def getMemoryQuotas(owner):
         owner_info = Owner.query().filter_by(owner_id=owner).first()
-- 
1.7.9.5