mkdir -p works if the directory already exists, so drop an unnecessary
[invirt/packages/invirt-dev.git] / debian / rules
index d35722d..4bde507 100755 (executable)
@@ -2,11 +2,16 @@
 
 DEB_PYTHON_SYSTEM=pysupport
 
+# We use --no-start instead of letting dh_installinit do its thing
+# because, in the postinst, dh_installinit's automatically added code
+# runs before dh_pysupport's automatically added code.
+#
+# This means that when the initscript is started, Python modules
+# installed by the package haven't been fully installed yet.
+DEB_DH_INSTALLINIT_ARGS += --no-start
+
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/python-distutils.mk
 
-install/invirt-dev::
-       cp debian/invirt-dev.upstart debian/invirt-dev/etc/event.d/invirt-dev
-
 clean::
        rm -rf python/invirt.builder.egg-info