projects
/
invirt/packages/invirt-dev.git
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
Revert previous commit. Our sbuild is not new enough
[invirt/packages/invirt-dev.git]
/
debian
/
invirt-dev.postinst
diff --git
a/debian/invirt-dev.postinst
b/debian/invirt-dev.postinst
index
d9b6b9b
..
9c17d85
100755
(executable)
--- a/
debian/invirt-dev.postinst
+++ b/
debian/invirt-dev.postinst
@@
-20,13
+20,15
@@
case "$1" in
mkdir -p /srv/git
fi
mkdir -p /srv/git
fi
- invirt-build-conf
-
cat >>/etc/sudoers <<EOF
### BEGIN invirt-dev
%repo ALL=(repository) ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
### END invirt-dev
EOF
cat >>/etc/sudoers <<EOF
### BEGIN invirt-dev
%repo ALL=(repository) ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
### END invirt-dev
EOF
+
+ update-inetd --add \
+ 'git\tstream\ttcp\tnowait\tgit\t/usr/bin/git\tgit daemon --inetd --syslog --verbose --export-all --base-path=/srv/git /srv/git'
+
echo "-----"
echo "invirt-dev: run"
echo " adduser --disabled-password \$user"
echo "-----"
echo "invirt-dev: run"
echo " adduser --disabled-password \$user"
@@
-34,6
+36,14
@@
EOF
echo " adduser \$user sbuild"
echo "to make individual users that will build packages."
echo "-----"
echo " adduser \$user sbuild"
echo "to make individual users that will build packages."
echo "-----"
+
+ invirt-configure-git-hooks || {
+ echo "-----"
+ echo "invirt-dev: Could not configure git hooks."
+ echo "Run 'invirt-configure-git-hooks' once you"
+ echo "have configured your repositories appropriately."
+ echo "-----"
+ }
;;
abort-upgrade|abort-remove|abort-deconfigure)
;;
abort-upgrade|abort-remove|abort-deconfigure)
@@
-44,3
+54,11
@@
EOF
exit 1
;;
esac
exit 1
;;
esac
+
+if [ -x /etc/init.d/invirtibuilder ]; then
+ if hash invoke-rc.d 2>/dev/null; then
+ invoke-rc.d invirtibuilder start
+ else
+ /etc/init.d/invirtibuilder start
+ fi
+fi