Use the systemv init script instead of an upstart job.
[invirt/packages/invirt-dev.git] / debian / invirt-dev.postinst
old mode 100644 (file)
new mode 100755 (executable)
index cc5164f..d9b6b9b
@@ -5,17 +5,35 @@ set -e
 
 case "$1" in
     configure)
-        if [ -z "$2" ]; then
+       if ! getent passwd repository >/dev/null 2>&1; then
             adduser --system repository
+       fi
+       if ! getent group repo >/dev/null 2>&1; then
             addgroup --system repo
-            echo "%repo   ALL=(repository)        ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro" >>/etc/sudoers
-            echo "-----"
-            echo "invirt-dev: run"
-            echo "  adduser --disabled-password \$user"
-            echo "  adduser \$user repo"
-            echo "to make individual users that will build packages."
-            echo "-----"
-        fi
+       fi
+
+       if ! getent passwd git >/dev/null 2>&1; then
+           adduser --system --home /srv/git --shell /usr/bin/git-shell git
+       fi
+
+       if ! [ -d /srv/git ]; then
+           mkdir -p /srv/git
+       fi
+
+       invirt-build-conf
+            
+        cat >>/etc/sudoers <<EOF
+### BEGIN invirt-dev
+%repo   ALL=(repository)        ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
+### END invirt-dev
+EOF
+        echo "-----"
+        echo "invirt-dev: run"
+        echo "  adduser --disabled-password \$user"
+        echo "  adduser \$user repo"
+        echo "  adduser \$user sbuild"
+        echo "to make individual users that will build packages."
+        echo "-----"
     ;;
 
     abort-upgrade|abort-remove|abort-deconfigure)