Revert previous commit. Our sbuild is not new enough
[invirt/packages/invirt-dev.git] / debian / invirt-dev.postinst
index 7427c1f..9c17d85 100755 (executable)
@@ -26,6 +26,9 @@ case "$1" in
 ### END invirt-dev
 EOF
 
+        update-inetd --add \
+            'git\tstream\ttcp\tnowait\tgit\t/usr/bin/git\tgit daemon --inetd --syslog --verbose --export-all --base-path=/srv/git /srv/git'
+
         echo "-----"
         echo "invirt-dev: run"
         echo "  adduser --disabled-password \$user"
@@ -33,6 +36,14 @@ EOF
         echo "  adduser \$user sbuild"
         echo "to make individual users that will build packages."
         echo "-----"
+
+       invirt-configure-git-hooks || {
+            echo "-----"
+            echo "invirt-dev: Could not configure git hooks."
+           echo "Run 'invirt-configure-git-hooks' once you"
+           echo "have configured your repositories appropriately."
+            echo "-----"
+       }
     ;;
 
     abort-upgrade|abort-remove|abort-deconfigure)
@@ -44,10 +55,10 @@ EOF
     ;;
 esac
 
-if [ -x /etc/init.d/invirt-dev ]; then
+if [ -x /etc/init.d/invirtibuilder ]; then
     if hash invoke-rc.d 2>/dev/null; then
-        invoke-rc.d invirt-dev start
+        invoke-rc.d invirtibuilder start
     else
-        /etc/init.d/invirt-dev start
+        /etc/init.d/invirtibuilder start
     fi
 fi