Pass --no-start to dh_installinit in invirt-dev and run the initscript
[invirt/packages/invirt-dev.git] / debian / invirt-dev.postinst
index 55bff25..7427c1f 100755 (executable)
@@ -16,13 +16,16 @@ case "$1" in
            adduser --system --home /srv/git --shell /usr/bin/git-shell git
        fi
 
-       invirt-build-conf
-            
+       if ! [ -d /srv/git ]; then
+           mkdir -p /srv/git
+       fi
+
         cat >>/etc/sudoers <<EOF
 ### BEGIN invirt-dev
 %repo   ALL=(repository)        ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
 ### END invirt-dev
 EOF
+
         echo "-----"
         echo "invirt-dev: run"
         echo "  adduser --disabled-password \$user"
@@ -40,3 +43,11 @@ EOF
         exit 1
     ;;
 esac
+
+if [ -x /etc/init.d/invirt-dev ]; then
+    if hash invoke-rc.d 2>/dev/null; then
+        invoke-rc.d invirt-dev start
+    else
+        /etc/init.d/invirt-dev start
+    fi
+fi