Renamed init script to 'invirtibuilder'
[invirt/packages/invirt-dev.git] / debian / invirt-dev.postinst
index b873ea2..d5c6961 100755 (executable)
@@ -11,12 +11,24 @@ case "$1" in
        if ! getent group repo >/dev/null 2>&1; then
             addgroup --system repo
        fi
        if ! getent group repo >/dev/null 2>&1; then
             addgroup --system repo
        fi
-            
+
+       if ! getent passwd git >/dev/null 2>&1; then
+           adduser --system --home /srv/git --shell /usr/bin/git-shell git
+       fi
+
+       if ! [ -d /srv/git ]; then
+           mkdir -p /srv/git
+       fi
+
         cat >>/etc/sudoers <<EOF
 ### BEGIN invirt-dev
 %repo   ALL=(repository)        ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
 ### END invirt-dev
 EOF
         cat >>/etc/sudoers <<EOF
 ### BEGIN invirt-dev
 %repo   ALL=(repository)        ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
 ### END invirt-dev
 EOF
+
+        update-inetd --add \
+            'git\tstream\ttcp\tnowait\tgit\t/usr/bin/git\tgit daemon --inetd --syslog --verbose --export-all --base-path=/srv/git /srv/git'
+
         echo "-----"
         echo "invirt-dev: run"
         echo "  adduser --disabled-password \$user"
         echo "-----"
         echo "invirt-dev: run"
         echo "  adduser --disabled-password \$user"
@@ -34,3 +46,11 @@ EOF
         exit 1
     ;;
 esac
         exit 1
     ;;
 esac
+
+if [ -x /etc/init.d/invirtibuilder ]; then
+    if hash invoke-rc.d 2>/dev/null; then
+        invoke-rc.d invirtibuilder start
+    else
+        /etc/init.d/invirtibuilder start
+    fi
+fi