projects
/
invirt/packages/invirt-dev.git
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
Only tag submodules if allow_backtracking is False.
[invirt/packages/invirt-dev.git]
/
debian
/
invirt-dev.postinst
diff --git
a/debian/invirt-dev.postinst
b/debian/invirt-dev.postinst
index
b873ea2
..
49fe62c
100755
(executable)
--- a/
debian/invirt-dev.postinst
+++ b/
debian/invirt-dev.postinst
@@
-11,12
+11,24
@@
case "$1" in
if ! getent group repo >/dev/null 2>&1; then
addgroup --system repo
fi
if ! getent group repo >/dev/null 2>&1; then
addgroup --system repo
fi
-
+
+ if ! getent passwd git >/dev/null 2>&1; then
+ adduser --system --home /srv/git --shell /usr/bin/git-shell git
+ fi
+
+ if ! [ -d /srv/git ]; then
+ mkdir -p /srv/git
+ fi
+
cat >>/etc/sudoers <<EOF
### BEGIN invirt-dev
%repo ALL=(repository) ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
### END invirt-dev
EOF
cat >>/etc/sudoers <<EOF
### BEGIN invirt-dev
%repo ALL=(repository) ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
### END invirt-dev
EOF
+
+ update-inetd --add \
+ 'git\tstream\ttcp\tnowait\tgit\t/usr/bin/git\tgit daemon --inetd --syslog --verbose --export-all --base-path=/srv/git /srv/git'
+
echo "-----"
echo "invirt-dev: run"
echo " adduser --disabled-password \$user"
echo "-----"
echo "invirt-dev: run"
echo " adduser --disabled-password \$user"
@@
-34,3
+46,11
@@
EOF
exit 1
;;
esac
exit 1
;;
esac
+
+if [ -x /etc/init.d/invirt-dev ]; then
+ if hash invoke-rc.d 2>/dev/null; then
+ invoke-rc.d invirt-dev start
+ else
+ /etc/init.d/invirt-dev start
+ fi
+fi