projects
/
invirt/packages/invirt-dev.git
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
Make the apt repo directory structure exist if it doesn't already.
[invirt/packages/invirt-dev.git]
/
debian
/
invirt-dev.postinst
diff --git
a/debian/invirt-dev.postinst
b/debian/invirt-dev.postinst
index
3574e88
..
7427c1f
100755
(executable)
--- a/
debian/invirt-dev.postinst
+++ b/
debian/invirt-dev.postinst
@@
-15,12
+15,17
@@
case "$1" in
if ! getent passwd git >/dev/null 2>&1; then
adduser --system --home /srv/git --shell /usr/bin/git-shell git
fi
if ! getent passwd git >/dev/null 2>&1; then
adduser --system --home /srv/git --shell /usr/bin/git-shell git
fi
-
+
+ if ! [ -d /srv/git ]; then
+ mkdir -p /srv/git
+ fi
+
cat >>/etc/sudoers <<EOF
### BEGIN invirt-dev
%repo ALL=(repository) ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
### END invirt-dev
EOF
cat >>/etc/sudoers <<EOF
### BEGIN invirt-dev
%repo ALL=(repository) ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
### END invirt-dev
EOF
+
echo "-----"
echo "invirt-dev: run"
echo " adduser --disabled-password \$user"
echo "-----"
echo "invirt-dev: run"
echo " adduser --disabled-password \$user"
@@
-38,3
+43,11
@@
EOF
exit 1
;;
esac
exit 1
;;
esac
+
+if [ -x /etc/init.d/invirt-dev ]; then
+ if hash invoke-rc.d 2>/dev/null; then
+ invoke-rc.d invirt-dev start
+ else
+ /etc/init.d/invirt-dev start
+ fi
+fi