Use the systemv init script instead of an upstart job.
[invirt/packages/invirt-dev.git] / debian / invirt-dev.postinst
index 3574e88..d9b6b9b 100755 (executable)
@@ -15,6 +15,12 @@ case "$1" in
        if ! getent passwd git >/dev/null 2>&1; then
            adduser --system --home /srv/git --shell /usr/bin/git-shell git
        fi
+
+       if ! [ -d /srv/git ]; then
+           mkdir -p /srv/git
+       fi
+
+       invirt-build-conf
             
         cat >>/etc/sudoers <<EOF
 ### BEGIN invirt-dev