X-Git-Url: http://xvm.mit.edu/gitweb/invirt/packages/invirt-dev.git/blobdiff_plain/7c3a9290d028f836eefad86ae124ef65248b9369..c26b08a9d7a315c88604ef88d66992b5392bcbc5:/debian/invirt-dev.postinst

diff --git a/debian/invirt-dev.postinst b/debian/invirt-dev.postinst
old mode 100644
new mode 100755
index 91fc673..d9b6b9b
--- a/debian/invirt-dev.postinst
+++ b/debian/invirt-dev.postinst
@@ -5,18 +5,35 @@ set -e
 
 case "$1" in
     configure)
-        if [ -z "$2" ]; then
+	if ! getent passwd repository >/dev/null 2>&1; then
             adduser --system repository
+	fi
+	if ! getent group repo >/dev/null 2>&1; then
             addgroup --system repo
-            echo "%repo   ALL=(repository)        ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro" >>/etc/sudoers
-            echo "-----"
-            echo "invirt-dev: run"
-            echo "  adduser --disabled-password \$user"
-            echo "  adduser \$user repo"
-            echo "  adduser \$user sbuild"
-            echo "to make individual users that will build packages."
-            echo "-----"
-        fi
+	fi
+
+	if ! getent passwd git >/dev/null 2>&1; then
+	    adduser --system --home /srv/git --shell /usr/bin/git-shell git
+	fi
+
+	if ! [ -d /srv/git ]; then
+	    mkdir -p /srv/git
+	fi
+
+	invirt-build-conf
+            
+        cat >>/etc/sudoers <<EOF
+### BEGIN invirt-dev
+%repo   ALL=(repository)        ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
+### END invirt-dev
+EOF
+        echo "-----"
+        echo "invirt-dev: run"
+        echo "  adduser --disabled-password \$user"
+        echo "  adduser \$user repo"
+        echo "  adduser \$user sbuild"
+        echo "to make individual users that will build packages."
+        echo "-----"
     ;;
 
     abort-upgrade|abort-remove|abort-deconfigure)