X-Git-Url: http://xvm.mit.edu/gitweb/invirt/packages/invirt-dev.git/blobdiff_plain/831bdddd73759def227e52088b61e22605e5f965..8eb9452bec2529dd0b4c8f426ddbeef9fae6480a:/debian/invirt-dev.postinst

diff --git a/debian/invirt-dev.postinst b/debian/invirt-dev.postinst
index 55bff25..7427c1f 100755
--- a/debian/invirt-dev.postinst
+++ b/debian/invirt-dev.postinst
@@ -16,13 +16,16 @@ case "$1" in
 	    adduser --system --home /srv/git --shell /usr/bin/git-shell git
 	fi
 
-	invirt-build-conf
-            
+	if ! [ -d /srv/git ]; then
+	    mkdir -p /srv/git
+	fi
+
         cat >>/etc/sudoers <<EOF
 ### BEGIN invirt-dev
 %repo   ALL=(repository)        ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
 ### END invirt-dev
 EOF
+
         echo "-----"
         echo "invirt-dev: run"
         echo "  adduser --disabled-password \$user"
@@ -40,3 +43,11 @@ EOF
         exit 1
     ;;
 esac
+
+if [ -x /etc/init.d/invirt-dev ]; then
+    if hash invoke-rc.d 2>/dev/null; then
+        invoke-rc.d invirt-dev start
+    else
+        /etc/init.d/invirt-dev start
+    fi
+fi