X-Git-Url: http://xvm.mit.edu/gitweb/invirt/packages/invirt-dev.git/blobdiff_plain/90dbf631b3e901a57314ff5d3a299ee5450457ff..281e0d0a1d636078a9a48395c753d5a10d78b63a:/debian/rules

diff --git a/debian/rules b/debian/rules
index ef4b266..7f3b99b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,14 @@
 
 DEB_PYTHON_SYSTEM=pysupport
 
+# We use --no-start instead of letting dh_installinit do its thing
+# because, in the postinst, dh_installinit's automatically added code
+# runs before dh_pysupport's automatically added code.
+#
+# This means that when the initscript is started, Python modules
+# installed by the package haven't been fully installed yet.
+DEB_DH_INSTALLINIT_ARGS += --no-start --name invirtibuilder
+
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/python-distutils.mk