X-Git-Url: http://xvm.mit.edu/gitweb/invirt/packages/invirt-dev.git/blobdiff_plain/b137288170a80f490b7468b9315d23f782562568..479b1cb73a333fa76e7d05f4000eb6267d8682c6:/debian/invirt-dev.postinst

diff --git a/debian/invirt-dev.postinst b/debian/invirt-dev.postinst
index f75d229..55bff25 100755
--- a/debian/invirt-dev.postinst
+++ b/debian/invirt-dev.postinst
@@ -5,23 +5,31 @@ set -e
 
 case "$1" in
     configure)
-        if [ -z "$2" ]; then
+	if ! getent passwd repository >/dev/null 2>&1; then
             adduser --system repository
+	fi
+	if ! getent group repo >/dev/null 2>&1; then
             addgroup --system repo
+	fi
+
+	if ! getent passwd git >/dev/null 2>&1; then
+	    adduser --system --home /srv/git --shell /usr/bin/git-shell git
+	fi
+
+	invirt-build-conf
             
-            cat >>/etc/sudoers <<EOF
+        cat >>/etc/sudoers <<EOF
 ### BEGIN invirt-dev
 %repo   ALL=(repository)        ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
 ### END invirt-dev
 EOF
-            echo "-----"
-            echo "invirt-dev: run"
-            echo "  adduser --disabled-password \$user"
-            echo "  adduser \$user repo"
-            echo "  adduser \$user sbuild"
-            echo "to make individual users that will build packages."
-            echo "-----"
-        fi
+        echo "-----"
+        echo "invirt-dev: run"
+        echo "  adduser --disabled-password \$user"
+        echo "  adduser \$user repo"
+        echo "  adduser \$user sbuild"
+        echo "to make individual users that will build packages."
+        echo "-----"
     ;;
 
     abort-upgrade|abort-remove|abort-deconfigure)