From ce5122124980b648e57e45727341299947a161fd Mon Sep 17 00:00:00 2001
From: Mitchell E Berger <mitchb@mit.edu>
Date: Sat, 29 Oct 2011 15:59:49 -0400
Subject: [PATCH] Style nit for Quentin

---
 debian/changelog |    6 ++++++
 invirt-dns       |    2 +-
 2 files changed, 7 insertions(+), 1 deletion(-)

diff --git a/debian/changelog b/debian/changelog
index 20b87e8..1f23e12 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+invirt-dns (0.0.13) unstable; urgency=low
+
+  * Style nit for Quentin
+
+ -- Mitchell Berger <mitchb@mit.edu>  Sat, 29 Oct 2011 15:59:00 -0400
+
 invirt-dns (0.0.12) unstable; urgency=low
 
   * Teach the DNS server how to delegate.
diff --git a/invirt-dns b/invirt-dns
index de53e0d..672d1f4 100755
--- a/invirt-dns
+++ b/invirt-dns
@@ -202,7 +202,7 @@ class DelegatingQuotingBindAuthority(authority.BindAuthority):
         # check if it's within a subdomain we're supposed to delegate to
         # some other DNS server.
         while (isinstance(deferredResult.result, failure.Failure)
-               and name.find('.') != -1):
+               and '.' in name):
             maybeDelegate = True
             name = name[name.find('.') + 1 :]
             deferredResult = authority.BindAuthority._lookup(self, name, cls,
-- 
1.7.9.5