From 8fa7103160f7a8e6663f88be13cb7a40e3032764 Mon Sep 17 00:00:00 2001
From: Greg Price <price@mit.edu>
Date: Thu, 5 Feb 2009 13:47:19 -0500
Subject: [PATCH 1/1] in invirt-remote-listvms, ignore another way VMs can
 disappear

svn path=/trunk/packages/invirt-remote/; revision=2098
---
 debian/changelog             |    6 ++++++
 host/usr/sbin/invirt-listvms |    2 +-
 2 files changed, 7 insertions(+), 1 deletion(-)

diff --git a/debian/changelog b/debian/changelog
index 31aa76a..15474f7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+invirt-remote (0.3.2) unstable; urgency=low
+
+  * in invirt-remote-listvms, ignore another way VMs can disappear
+
+ -- Greg Price <price@mit.edu>  Thu, 05 Feb 2009 13:43:46 -0500
+
 invirt-remote (0.3.1) unstable; urgency=low
 
   * invirt.remote.bcast: provide stderr text when remctl fails
diff --git a/host/usr/sbin/invirt-listvms b/host/usr/sbin/invirt-listvms
index 890931a..c16a883 100755
--- a/host/usr/sbin/invirt-listvms
+++ b/host/usr/sbin/invirt-listvms
@@ -17,7 +17,7 @@ def live_vms():
             name, data = get_dom(int(domid))
         except (xs.Error, TypeError):
             continue # went down since we started
-        if name.startswith('d_'):
+        if name is not None and name.startswith('d_'):
             name = name[2:]
             vms[name] = data
     return vms
-- 
1.7.9.5