From f7c3f820af76d0fc4d25caa836c2a03fb8f5fd7b Mon Sep 17 00:00:00 2001
From: Evan Broder <broder@mit.edu>
Date: Tue, 28 Oct 2008 20:00:21 -0400
Subject: [PATCH] Add a `remote control vnctoken` remctl for generating a VNC
 auth token

svn path=/trunk/packages/invirt-remote-host/; revision=1390
---
 debian/changelog                |    7 +++++++
 debian/control                  |    3 ++-
 files/usr/sbin/invirt-vmcontrol |    2 ++
 3 files changed, 11 insertions(+), 1 deletion(-)

diff --git a/debian/changelog b/debian/changelog
index 777635e..d23e4ac 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+invirt-remote-host (0.0.3) unstable; urgency=low
+
+  * Add support for a `remote control vnctoken` remctl for generating a
+    VNC auth token
+
+ -- Evan Broder <broder@mit.edu>  Tue, 28 Oct 2008 19:47:22 -0400
+
 invirt-remote-host (0.0.2) unstable; urgency=low
 
   * sipb-database -> invirt-database
diff --git a/debian/control b/debian/control
index 0f8cd5d..0700a91 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,8 @@ Standards-Version: 3.8.0
 
 Package: invirt-remote-host
 Architecture: all
-Depends: ${misc:Depends}, remctl-server, invirt-console-host, python-cjson, python-yaml
+Depends: ${misc:Depends}, remctl-server, invirt-console-host,
+ invirt-vnc-server, python-cjson, python-yaml
 Description: Installs the Invirt host remctl configuration
  This is the remctl configuration for an Invirt host. It allows any
  commands to be run from the Invirt remote server
diff --git a/files/usr/sbin/invirt-vmcontrol b/files/usr/sbin/invirt-vmcontrol
index bb3006b..520aebd 100755
--- a/files/usr/sbin/invirt-vmcontrol
+++ b/files/usr/sbin/invirt-vmcontrol
@@ -40,6 +40,8 @@ case "$ACTION" in
     list-long)
 	xm list --long "$MACHINE"
 	;;
+    vnctoken)
+        invirt-vnc-authtoken "$ORIGMACHINE"
     *)
         echo "ERROR: Invalid Command"
         exit 34
-- 
1.7.9.5