From 68c13b96a4ad8b33f0bbf607fa0230b88a879e65 Mon Sep 17 00:00:00 2001
From: Mitchell E Berger <mitchb@mit.edu>
Date: Mon, 31 Oct 2011 20:38:37 -0400
Subject: [PATCH] Tell users to contact us at our support address, not our
 automated error mail address, if we run out of IPs.

---
 code/controls.py |    2 +-
 debian/changelog |    7 +++++++
 2 files changed, 8 insertions(+), 1 deletion(-)

diff --git a/code/controls.py b/code/controls.py
index d04b2f5..6346002 100644
--- a/code/controls.py
+++ b/code/controls.py
@@ -116,7 +116,7 @@ def createVm(username, state, owner, contact, name, description, memory, disksiz
         nic = NIC.query().filter_by(machine_id=None).filter_by(reusable=True).first()
         if not nic: #No IPs left!
             raise CodeError("No IP addresses left!  "
-                            "Contact %s." % config.web.errormail)
+                            "Contact %s." % config.contact)
         nic.machine = machine
         nic.hostname = name
         session.save_or_update(nic)
diff --git a/debian/changelog b/debian/changelog
index 91bffee..68fcf66 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+invirt-web (0.1.20) unstable; urgency=low
+
+  * Tell users to contact us at our support address, not our
+    automated error mail address, if we run out of IPs.
+
+ -- Mitchell Berger <mitchb@mit.edu>  Mon, 31 Oct 2011 20:38:00 -0400
+
 invirt-web (0.1.19) unstable; urgency=low
 
   * Fix path to gitweb static content
-- 
1.7.9.5