Fix the fact that we can't bump RAM quotas above 2048M
[invirt/packages/invirt-xen-config.git] / debian / changelog
index b03e8b4..ff5d141 100644 (file)
@@ -1,3 +1,206 @@
+invirt-xen-config (0.0.59) unstable; urgency=low
+
+  * Fix the fact that we can't bump RAM quotas above 2048M
+    (and acknowledge the reality that 2048M really isn't the rarest
+    thing to need these days)
+
+  Quoting from history:
+
+  """
+     invirt-xen-config (0.0.15) unstable; urgency=low
+
+       * Set the max memory to a really high number so we can bump it for users
+       * Pass the correct networking device to vif-invirtroute
+
+      -- Evan Broder <broder@mit.edu>  Fri, 14 Nov 2008 00:03:47 -0500
+  """
+
+  i,i "640K ought to be enough for anyone."
+
+ -- Mitchell Berger <mitchb@mit.edu>  Tue, 23 Jul 2019 18:50:00 -0400
+
+invirt-xen-config (0.0.58) unstable; urgency=low
+
+  * Support kickstart-based Fedora autoinstalls.
+
+ -- Quentin Smith <quentin@mit.edu>  Sat, 15 Jun 2019 20:59:54 -0400
+
+invirt-xen-config (0.0.57) unstable; urgency=low
+
+  * invirt-database: Fix the autoinstall logic so that if we've
+    increased the memory temporarily for the autoinstall above
+    the machine's database setting, we also bring maxmem up to
+    the same level.  Otherwise the machine doesn't turn on
+    because it's requesting to start with more memory than maxmem,
+    and this failure mode is silent to the user.
+
+ -- Mitchell Berger <mitchb@mit.edu>  Sat, 02 Feb 2019 16:52:00 -0500
+
+invirt-xen-config (0.0.56) unstable; urgency=low
+
+  * vif-invirtroute: Kill arpspoof with SIGKILL when we're done.  The
+    version in this distro (which is the latest beta from the
+    unmaintained upstream) tries to "clean up" when you normally
+    terminate it.  This involves trying to perform an ARP lookup
+    without interfering to see what the MAC should've been and then
+    sending replies for that.  This appears to cause a race depending
+    on whether the entry for the machine's old domain (if it's being
+    rebooted) is listed as <incomplete> in the ARP table or is totally
+    flushed.  If you lose the race, it sends further gratuitous ARPs
+    telling the router that your MAC is all-zeros because of a bug
+    where it fails to check for an incomplete ARP entry.  This is
+    believed to cause the bug that has plagued XVM for years where
+    you sometimes lose off-network connectivity on reboot.
+
+ -- Mitchell Berger <mitchb@mit.edu>  Mon, 25 Jun 2018 22:04:00 -0400
+
+invirt-xen-config (0.0.55) unstable; urgency=low
+
+  * invirt-database: bump up autoinstall memory to make modern releases
+    work again.
+
+ -- Mitchell Berger <mitchb@mit.edu>  Fri, 01 Jun 2018 02:17:00 -0400
+
+invirt-xen-config (0.0.54) unstable; urgency=low
+
+  * invirt-database: handle several possible actions to take with an
+    "other" set of network parameters.  Renumber a machine by swapping
+    the sets of netparams, DNAT from an old address by passing through
+    additional parameters to vif-invirtroute, and teardown an IP
+    transition by clearing all the "other" values.  Also, use the
+    netmask and gateway for the VM when autoinstalling, rather than
+    parameters from the global cluster configuration.
+  * vif-invirtroute: if there is an "other" IP address, DNAT it to the
+    primary IP, set up routing to get it to the VM, and arp for it.
+    Also, cut out the nonsense with backgrounding arpspoof, sleeping, and
+    killing it; we have the technology for 'timeout'.  Finally, don't
+    pass a "src" argument to "ip route del" to ensure a match even if
+    the host's "main IP" has changed and caused the route to be inserted
+    with a different src.
+  * templatize-xend-config: explicitly turn on the relocation server
+  * qemu-ifup.invirt: make HVMs work and not only if your eth0 just happens
+    to have an IPv4 network address sitting on it
+
+ -- Mitchell Berger <mitchb@mit.edu>  Sun, 27 May 2018 01:45:00 -0400
+
+invirt-xen-config (0.0.53) unstable; urgency=low
+
+  * Fix machine UUID assignment after SQLAlchemy started returning Unicode
+    objects.
+
+ -- Quentin Smith <quentin@mit.edu>  Mon, 06 Jan 2014 22:02:11 -0500
+
+invirt-xen-config (0.0.52) UNRELEASED; urgency=low
+
+  * Fix PVHVM networking
+
+ -- Adam Glasgall <glasgall@mit.edu>  Mon, 02 Sep 2013 21:16:01 -0400
+
+invirt-xen-config (0.0.51) unstable; urgency=low
+
+  * Fixed code for NIC model options.
+
+ -- Steven Valdez <dvorak42@mit.edu>  Wed, 31 Jul 2013 22:28:39 -0400
+
+invirt-xen-config (0.0.50) unstable; urgency=low
+
+  * Adding NIC model option to DB.
+
+ -- Steven Valdez <dvorak42@mit.edu>  Fri, 26 Jul 2013 22:28:47 -0400
+
+invirt-xen-config (0.0.49) precise; urgency=low
+
+  * Change HVM emulated network card to pcnet, because the emulated
+    realtek hardware is as bad as the real realtek hardware.
+
+ -- Adam Glasgall <glasgall@mit.edu>  Tue, 23 Jul 2013 02:52:06 -0400
+
+invirt-xen-config (0.0.48) precise; urgency=low
+
+  * Disable PVHVM for now until we figure out the best way to do it
+
+ -- Adam Glasgall <glasgall@mit.edu>  Mon, 22 Jul 2013 01:08:40 -0400
+
+invirt-xen-config (0.0.47) unstable; urgency=low
+
+  * Blame glasgall for the wasted version number.
+
+ -- Quentin Smith <quentin@mit.edu>  Sun, 21 Jul 2013 14:55:00 -0400
+
+invirt-xen-config (0.0.46) unstable; urgency=low
+
+  * Non-hotplug events apparently also use vif-setup.
+
+ -- Quentin Smith <quentin@mit.edu>  Sun, 21 Jul 2013 14:49:54 -0400
+
+invirt-xen-config (0.0.45) unstable; urgency=low
+
+  * Neuter vif-setup (from xl, perhaps?)
+  * Update vif-invirtroute for Xen 4's scripts.
+
+ -- Quentin Smith <quentin@mit.edu>  Sun, 21 Jul 2013 14:28:58 -0400
+
+invirt-xen-config (0.0.44) unstable; urgency=low
+
+  * Disable populate-on-demand for HVMs.
+
+ -- Quentin Smith <quentin@mit.edu>  Sun, 21 Jul 2013 13:14:53 -0400
+
+invirt-xen-config (0.0.43+nmu1) precise; urgency=low
+
+  * Use config-package-dev.
+
+ -- Alexander Chernyakhovsky <achernya@mit.edu>  Sun, 21 Jul 2013 12:48:47 -0400
+
+invirt-xen-config (0.0.43) precise; urgency=low
+
+  * fix the diversion too.
+
+ -- Adam Glasgall <glasgall@mit.edu>  Sun, 21 Jul 2013 01:14:41 -0400
+
+invirt-xen-config (0.0.42) precise; urgency=low
+
+  * qemu-ifup moved from /etc/xen to /etc/xen/scripts
+
+ -- Adam Glasgall <glasgall@mit.edu>  Sun, 21 Jul 2013 01:06:27 -0400
+
+invirt-xen-config (0.0.41) precise; urgency=low
+
+  * no-change rebuild
+
+ -- Adam Glasgall <glasgall@mit.edu>  Sat, 20 Jul 2013 16:54:56 -0400
+
+invirt-xen-config (0.0.40) precise; urgency=low
+
+  * Updating version for precise.
+
+ -- Steven Valdez <dvorak42@mit.edu>  Sat, 20 Jul 2013 16:46:47 -0400
+
+invirt-xen-config (0.0.39) unstable; urgency=low
+
+  * Treat config.hosts.internal_ips as an array
+
+ -- Peter Iannucci <iannucci@mit.edu>  Mon, 01 Jul 2013 21:51:00 -0400
+
+invirt-xen-config (0.0.38~glasgall15) precise; urgency=low
+
+  * Teach qemu-dm-invirt that /usr/lib/xen moved to /usr/lib/xen-4.1
+
+ -- Adam Glasgall <glasgall@mit.edu>  Thu, 06 Jun 2013 21:36:37 -0400
+
+invirt-xen-config (0.0.38~glasgall14achernya1) precise; urgency=low
+
+  * Switch to dh7
+  * Bump standards version
+
+ -- Alexander Chernyakhovsky <achernya@mit.edu>  Fri, 31 May 2013 21:16:20 -0400
+
+invirt-xen-config (0.0.38~glasgall14) precise; urgency=low
+
+  * /usr/lib/xen moved to /usr/lib/xen-4.1. teach invirt-database this.
+
+ -- Adam Glasgall <glasgall@mit.edu>  Wed, 08 May 2013 00:06:25 -0400
+
 invirt-xen-config (0.0.38~glasgall13) precise; urgency=low
 
   * Undo enabling network-bridge; we want to manage our own bridge config