#!/bin/sh
# postinst script for xvm-iscsi-config
#
# see: dh_installdeb(1)

set -e

# Source debconf library
. /usr/share/debconf/confmodule

# summary of how this script can be called:
#        * <postinst> `configure' <most-recently-configured-version>
#        * <old-postinst> `abort-upgrade' <new version>
#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
#          <new-version>
#        * <postinst> `abort-remove'
#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
#          <failed-install-package> <version> `removing'
#          <conflicting-package> <version>
# for details, see http://www.debian.org/doc/debian-policy/ or
# the debian-policy package


case "$1" in
    configure)
        db_get xvm-iscsi-config/address
        ADDRESS="$RET"
        db_get xvm-iscsi-config/username
        USERNAME="$RET"
        db_get xvm-iscsi-config/password
        PASSWORD="$RET"
        
        cat >/etc/invirt/conf.d/iscsi <<EOF
iscsi:
 address: $ADDRESS
 username: $USERNAME
 password: $PASSWORD
EOF
        invoke-rc.d xvm-iscsi-config restart
        invoke-rc.d open-iscsi restart
        iscsiadm -m discovery -t st -p $(invirt-getconf iscsi.address):3260
    ;;

    abort-upgrade|abort-remove|abort-deconfigure)
    ;;

    *)
        echo "postinst called with unknown argument \`$1'" >&2
        exit 1
    ;;
esac

# dh_installdeb will replace this with shell code automatically
# generated by other debhelper scripts.

#DEBHELPER#

exit 0