X-Git-Url: http://xvm.mit.edu/gitweb/invirt/packages/xvm-munin-config.git/blobdiff_plain/54ac87f30ffb5787f4bf02a6c7bd7f44f8313e39..3b7041eaf403cb57a8f41cb767a16f6bb0442726:/debian/xvm-munin-host-config.postinst?ds=sidebyside

diff --git a/debian/xvm-munin-host-config.postinst b/debian/xvm-munin-host-config.postinst
index 3dbbeb6..fc2de88 100755
--- a/debian/xvm-munin-host-config.postinst
+++ b/debian/xvm-munin-host-config.postinst
@@ -23,9 +23,6 @@ case "$1" in
         # So munin can read the mail log
         adduser munin adm
         
-        # First clear out the old stuff we threw in /etc/sudoers
-        perl -i.bak -ne 's%^### (BEGIN|END) xvm-munin-config\s*$%%m && ($skip = ($1 eq "BEGIN")); print unless $skip;' /etc/sudoers
-        
         # So munin can sudo to get to postfix queue info
         # and smartctl info
         # and info about running domains
@@ -39,6 +36,13 @@ EOF
         
         # Install munin plugins that are now configured
         munin-node-configure --suggest --shell | sh
+
+	(cd /etc/munin/plugins &&
+	    for i in smart_*; do
+		if smartctl -i "/dev/${i#smart_}" | grep Device | grep EQLOGIC; then
+		    rm -v "$i";
+		fi
+	    done)
         
         invoke-rc.d munin-node restart
     ;;