X-Git-Url: http://xvm.mit.edu/gitweb/invirt/packages/xvm-munin-config.git/blobdiff_plain/56328c0b20eb97049d9552298ac41f316a445a47..refs/heads/prod:/debian/xvm-munin-host-config.postinst?ds=sidebyside

diff --git a/debian/xvm-munin-host-config.postinst b/debian/xvm-munin-host-config.postinst
index ce981db..fc2de88 100755
--- a/debian/xvm-munin-host-config.postinst
+++ b/debian/xvm-munin-host-config.postinst
@@ -24,6 +24,8 @@ case "$1" in
         adduser munin adm
         
         # So munin can sudo to get to postfix queue info
+        # and smartctl info
+        # and info about running domains
         cat >>/etc/sudoers <<EOF
 ### BEGIN xvm-munin-config
 munin ALL=(postfix) SETENV: NOPASSWD: /etc/munin/plugins/postfix_mailqueue
@@ -34,6 +36,13 @@ EOF
         
         # Install munin plugins that are now configured
         munin-node-configure --suggest --shell | sh
+
+	(cd /etc/munin/plugins &&
+	    for i in smart_*; do
+		if smartctl -i "/dev/${i#smart_}" | grep Device | grep EQLOGIC; then
+		    rm -v "$i";
+		fi
+	    done)
         
         invoke-rc.d munin-node restart
     ;;