projects
/
invirt/packages/hvirt-config.git
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
Updated hvirt devconfig
[invirt/packages/hvirt-config.git]
/
debian
/
hvirt-devconfig.postinst
diff --git
a/debian/hvirt-devconfig.postinst
b/debian/hvirt-devconfig.postinst
old mode 100644
(file)
new mode 100755
(executable)
index
b52fc9d
..
3f448f8
--- a/
debian/hvirt-devconfig.postinst
+++ b/
debian/hvirt-devconfig.postinst
@@
-1,5
+1,5
@@
#!/bin/sh
#!/bin/sh
-# postinst script for #PACKAGE#
+# postinst script for hvirt-devconfig
#
# see: dh_installdeb(1)
#
# see: dh_installdeb(1)
@@
-17,19
+17,15
@@
set -e
# for details, see http://www.debian.org/doc/debian-policy/ or
# the debian-policy package
# for details, see http://www.debian.org/doc/debian-policy/ or
# the debian-policy package
+
case "$1" in
configure)
case "$1" in
configure)
- # Need to do it like this to avoid shell injection
- /usr/bin/perl -i -e '$r = `invirt-getconf kerberos.realm`; $r.chomp;
- while(<>) { s/^([ \t]*default_realm *=).*$/\1 $r/m; print; }' /etc/krb5.conf.invirt
+ invirt-reload
;;
abort-upgrade|abort-remove|abort-deconfigure)
;;
;;
abort-upgrade|abort-remove|abort-deconfigure)
;;
- triggered)
- ;;
-
*)
echo "postinst called with unknown argument \`$1'" >&2
exit 1
*)
echo "postinst called with unknown argument \`$1'" >&2
exit 1
@@
-42,5
+38,3
@@
esac
#DEBHELPER#
exit 0
#DEBHELPER#
exit 0
-
-