2 # postinst script for invirt-console-host
4 # see: dh_installdeb(1)
8 # summary of how this script can be called:
9 # * <postinst> `configure' <most-recently-configured-version>
10 # * <old-postinst> `abort-upgrade' <new version>
11 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
13 # * <postinst> `abort-remove'
14 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15 # <failed-install-package> <version> `removing'
16 # <conflicting-package> <version>
17 # for details, see http://www.debian.org/doc/debian-policy/ or
18 # the debian-policy package
23 cat >>/etc/sudoers <<EOF
24 ### BEGIN invirt-console-host
25 conservr ALL=(ALL) NOPASSWD: /usr/sbin/xm console d_*
26 ### END invirt-console-host
30 abort-upgrade|abort-remove|abort-deconfigure)
34 echo "postinst called with unknown argument \`$1'" >&2
39 # dh_installdeb will replace this with shell code automatically
40 # generated by other debhelper scripts.