1 invirt-database (0.2.0) unstable; urgency=low
3 * Merge invirt-database-server into invirt-database.
5 -- Evan Broder <broder@mit.edu> Fri, 27 Feb 2009 19:38:55 -0500
7 invirt-database (0.1.9) unstable; urgency=low
9 * Make get*Quotas idempotent
10 * Move Owner import so that Owner can access session in
11 invirt.database.models
13 -- Quentin Smith <quentin@mit.edu> Fri, 27 Feb 2009 14:17:53 -0500
15 invirt-database (0.1.8) unstable; urgency=low
18 * Added Record superclass for models, handling __repr__ consistently.
21 invirt.database.record, .owner:
22 * use self.c rather than self.__dict__ for SQLAlchemy fields
23 * make Record._ignore, Owner.get* classmethods
24 * fold FormattableRecord, NullableRecord into Record
25 * shorten types in lists to __name__
28 * refactor code that sets values
29 * print full help on no arguments
35 * Add "reusable" column for nics, to avoid reusing addresses that are
38 -- Quentin Smith <quentin@mit.edu> Fri, 27 Feb 2009 11:51:39 -0500
40 invirt-database (0.1.7) unstable; urgency=low
42 * Disk quotas are measured in gibibytes.
43 * Rename invirt-setquotas to invirt-quota.
44 * Be explicit about units in invirt-quota.
46 -- Evan Broder <broder@mit.edu> Tue, 17 Feb 2009 04:29:20 -0500
48 invirt-database (0.1.6) unstable; urgency=low
50 * Move invirt-setquotas into this package.
51 * Don't explicitly initialize the values for each quota when creating a
54 -- Evan Broder <broder@mit.edu> Tue, 17 Feb 2009 03:44:20 -0500
56 invirt-database (0.1.5) unstable; urgency=low
58 * Make the default values on the owners table explicit
59 (Note: This is a NOOP, since a nullable field with no otherwise
60 specified default defaults to NULL)
62 -- Evan Broder <broder@mit.edu> Tue, 17 Feb 2009 03:36:47 -0500
64 invirt-database (0.1.4) unstable; urgency=low
68 -- Peter A. Iannucci <iannucci@mit.edu> Tue, 17 Feb 2009 02:59:14 -0500
70 invirt-database (0.1.3) unstable; urgency=low
72 * Added owner table to database with ram, disk, and VM quotas
73 * Refactored Owner class into separate sourcefile
75 -- Peter A. Iannucci <iannucci@mit.edu> Tue, 17 Feb 2009 01:31:53 -0500
77 invirt-database (0.1.2) unstable; urgency=low
79 * Clean up the .egg-info directory from the right place.
81 -- Evan Broder <broder@mit.edu> Mon, 05 Jan 2009 23:50:47 -0500
83 invirt-database (0.1.1) unstable; urgency=low
85 * Correct a lintian spelling warning.
87 -- Evan Broder <broder@mit.edu> Mon, 05 Jan 2009 23:40:44 -0500
89 invirt-database (0.1.0) unstable; urgency=low
91 * Turn on lazy loading for all tables
93 -- Evan Broder <broder@mit.edu> Mon, 17 Nov 2008 21:57:35 -0500
95 invirt-database (0.0.6) unstable; urgency=low
97 * Let machines.administrator be NULL
99 -- Evan Broder <broder@mit.edu> Mon, 17 Nov 2008 13:41:48 -0500
101 invirt-database (0.0.5) unstable; urgency=low
103 * Add an architecture field to the autoinstaller table
105 -- Evan Broder <broder@mit.edu> Mon, 17 Nov 2008 12:18:02 -0500
107 invirt-database (0.0.3) unstable; urgency=low
109 * Add attributes to the ORM objects to connect mirrors and cdroms
111 -- Evan Broder <broder@mit.edu> Tue, 28 Oct 2008 03:16:18 -0400
113 invirt-database (0.0.2) unstable; urgency=low
115 * Export mirrors_table and Mirrors from invirt.database.models
117 -- Evan Broder <broder@mit.edu> Tue, 28 Oct 2008 03:04:54 -0400
119 invirt-database (0.0.1) unstable; urgency=low
121 * sipb-xen-database-common -> invirt-database
122 * sipb-xen-database-server -> invirt-database-server (a separate source package)
123 * sipb-xen-database-client -> invirt-xen-config
125 -- Evan Broder <broder@mit.edu> Sat, 25 Oct 2008 19:22:46 -0400
127 sipb-xen-database (10.36.1) unstable; urgency=low
129 * Typo in the new tables
131 -- Evan Broder <broder@mit.edu> Sat, 25 Oct 2008 15:01:47 -0400
133 sipb-xen-database (10.36) unstable; urgency=low
135 * Kill the remnants of the sipb_xen_database package
136 * Add the CDROM mirrors table
138 -- Evan Broder <broder@mit.edu> Sat, 25 Oct 2008 14:48:32 -0400
140 sipb-xen-database (10.35) unstable; urgency=low
142 * Shorten initscript with spiffy new library from sipb-xen-base
144 -- Greg Price <price@mit.edu> Fri, 24 Oct 2008 07:25:56 -0400
146 sipb-xen-database (10.34) unstable; urgency=low
148 * yet another new-sqlalchemy fix, this one post-0.4.2
150 -- Greg Price <price@mit.edu> Thu, 23 Oct 2008 23:02:46 -0400
152 sipb-xen-database (10.33) unstable; urgency=low
154 * Catch calls to restart Postgres and translate them into a sequential
157 -- Evan Broder <broder@mit.edu> Mon, 20 Oct 2008 13:05:29 -0400
159 sipb-xen-database (10.32) unstable; urgency=low
161 * invirt.database.clear_cache should actually do something
163 -- Evan Broder <broder@mit.edu> Sun, 19 Oct 2008 02:02:37 -0400
165 sipb-xen-database (10.31) unstable; urgency=low
167 * Database-managed VMs should never even think about bridging
169 -- Evan Broder <broder@mit.edu> Sun, 19 Oct 2008 01:46:45 -0400
171 sipb-xen-database (10.30.4) unstable; urgency=low
173 * Fix a typo in the CDROM image path
175 -- Evan Broder <broder@mit.edu> Wed, 15 Oct 2008 13:21:10 -0400
177 sipb-xen-database (10.30.3) unstable; urgency=low
179 * fix copy-paste errors in initscript: this is database, not console
180 * fix "typo" in initscript for package name printed in logs
182 -- Greg Price <price@mit.edu> Sat, 11 Oct 2008 17:50:11 -0700
184 sipb-xen-database (10.30.2) unstable; urgency=low
186 * Fix a typo in the CDROM lookup in sipb-database
188 -- Evan Broder <broder@mit.edu> Sat, 11 Oct 2008 19:17:05 -0400
190 sipb-xen-database (10.30.1) unstable; urgency=low
192 * Don't strip quotes that won't be there
194 -- Evan Broder <broder@mit.edu> Fri, 10 Oct 2008 01:48:48 -0400
196 sipb-xen-database (10.30) unstable; urgency=low
198 * Look for CD images in /dev/xenvg/image_* and validate image name from
200 * Pass the installer arguments unaltered to the kernel, matching the
203 -- Evan Broder <broder@mit.edu> Thu, 09 Oct 2008 02:09:42 -0400
205 sipb-xen-database (10.29) unstable; urgency=low
207 * Some fixes in the sipb-database script
209 -- Evan Broder <broder@mit.edu> Mon, 06 Oct 2008 18:55:24 -0400
211 sipb-xen-database (10.28) unstable; urgency=low
213 * Re-establish the database connection if the server goes AWOL
215 -- Evan Broder <broder@mit.edu> Sat, 04 Oct 2008 23:19:59 -0400
217 sipb-xen-database (10.27) unstable; urgency=low
219 * Update sipb-database to work with newer SQLAlchemy and Xen
221 -- Evan Broder <broder@mit.edu> Fri, 03 Oct 2008 20:08:16 -0400
223 sipb-xen-database (10.26.1) unstable; urgency=low
225 * We want autoflush off, too
227 -- Evan Broder <broder@mit.edu> Fri, 03 Oct 2008 19:22:12 -0400
229 sipb-xen-database (10.26) unstable; urgency=low
231 * Disable transactions by default
233 -- Evan Broder <broder@mit.edu> Thu, 02 Oct 2008 19:40:34 -0400
235 sipb-xen-database (10.25) unstable; urgency=low
237 * add remote and console to pg_hba.conf template
238 * fix init script so it works
239 * port more code to sqlalchemy 0.4
241 -- Greg Price <price@mit.edu> Wed, 01 Oct 2008 19:30:26 -0400
243 sipb-xen-database (10.24) unstable; urgency=low
245 * Update postgresql.conf for Hardy
247 -- Evan Broder <broder@mit.edu> Wed, 01 Oct 2008 03:12:36 -0400
249 sipb-xen-database (10.23) unstable; urgency=low
251 * switch to postgresql 8.3, as 8.1 isn't in hardy
253 -- Greg Price <price@mit.edu> Wed, 01 Oct 2008 02:09:43 -0400
255 sipb-xen-database (10.22) unstable; urgency=low
257 * depend on postgresql without specifying old version 8.1
259 -- Greg Price <price@mit.edu> Wed, 01 Oct 2008 01:55:49 -0400
261 sipb-xen-database (10.21) unstable; urgency=low
265 -- Greg Price <price@mit.edu> Tue, 30 Sep 2008 23:50:25 -0400
267 sipb-xen-database (10.20) hardy; urgency=low
269 * port to sqlalchemy-0.4, which cuts out some newly deprecated
270 interfaces and allowed some still-present interfaces to bitrot
272 -- Greg Price <price@mit.edu> Mon, 29 Sep 2008 06:06:21 +0000
274 sipb-xen-database (10.19) unstable; urgency=low
276 * Generate config files for pg_hba.conf
277 * replace postgresql.conf
279 -- Sam Hartman <hartmans@xvm.mit.edu> Mon, 25 Aug 2008 00:38:21 +0000
281 sipb-xen-database (10.18) unstable; urgency=low
283 * add 'adminable' column to machines; for selectively, temporarily,
284 enabling admin mode on a machine
286 -- Greg Price <price@mit.edu> Wed, 6 Aug 2008 01:02:59 -0400
288 sipb-xen-database (10.17) unstable; urgency=low
290 * pull IP gateway, network from config
291 * configurabilization complete!
293 -- Greg Price <price@mit.edu> Sun, 3 Aug 2008 01:16:53 -0400
295 sipb-xen-database (10.16) unstable; urgency=low
297 in sipb-xen-database-tables:
298 * use invirt.database, and take default db uri
300 -- Greg Price <price@mit.edu> Sun, 3 Aug 2008 00:51:32 -0400
302 sipb-xen-database (10.15) unstable; urgency=low
304 in /etc/xen/database:
305 * uncommitted changes on black-mesa
306 * sipb_xen_database -> invirt.database
310 * get default db uri from invirt.config
312 -- Greg Price <price@mit.edu> Sun, 3 Aug 2008 00:26:46 -0400
314 sipb-xen-database (10.14) unstable; urgency=low
316 * Rename sipb_xen_database -> invirt.database,
317 keeping old name too for now, for compatibility.
319 -- Greg Price <price@mit.edu> Sat, 2 Aug 2008 23:19:18 -0400
321 sipb-xen-database (10.13) unstable; urgency=low
323 * Modify autoinstalls table to specify distribution/mirror.
325 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Sat, 21 Jun 2008 21:25:21 -0400
327 sipb-xen-database (10.12) unstable; urgency=low
329 * Add a description field.
331 -- Anders Kaseorg <andersk@mit.edu> Wed, 18 Jun 2008 03:52:49 -0400
333 sipb-xen-database (10.11) unstable; urgency=low
335 * Specify ON DELETE CASCADE
337 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 06 Jun 2008 12:25:35 -0400
339 sipb-xen-database (10.10) unstable; urgency=low
341 * Make machine.acl a private relation.
343 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 06 Jun 2008 12:03:09 -0400
345 sipb-xen-database (10.9) unstable; urgency=low
347 * Eager loading of relations for better performance.
349 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Mon, 02 Jun 2008 01:39:11 -0400
351 sipb-xen-database (10.8) unstable; urgency=low
353 * Configure serial console on boot
355 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Thu, 1 May 2008 20:21:25 -0400
357 sipb-xen-database (10.7) unstable; urgency=low
359 * Depend on psql client in -client package.
361 -- Greg Price <price@mit.edu> Sat, 26 Apr 2008 21:06:41 -0400
363 sipb-xen-database (10.6) unstable; urgency=low
365 * Support autoinstalls table.
367 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Mon, 21 Apr 2008 22:34:46 -0400
369 sipb-xen-database (10.5) unstable; urgency=low
371 * Enable USB tablet device in guests.
373 -- Anders Kaseorg <andersk@mit.edu> Mon, 21 Apr 2008 17:39:59 -0400
375 sipb-xen-database (10.4.1) unstable; urgency=low
377 * Actually export the cache clearing function.
379 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 28 Mar 2008 21:18:01 -0400
381 sipb-xen-database (10.4) unstable; urgency=low
383 * Ubuntu's dch sucks.
385 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Fri, 28 Mar 2008 20:43:42 -0400
387 sipb-xen-database (10.3ubuntu1) gutsy; urgency=low
389 * Expose a function for clearing the cache.
391 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 28 Mar 2008 20:31:06 -0400
393 sipb-xen-database (10.3) unstable; urgency=low
395 * Use 'acl', not 'users', for the reference to the machine_access table.
397 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Thu, 24 Jan 2008 17:23:33 -0500
399 sipb-xen-database (10.2) unstable; urgency=low
401 * Add MachineAccess to __all__ so it can be imported
402 * Remove unnecessary constructors for database objects
404 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Mon, 12 Nov 2007 04:53:47 -0500
406 sipb-xen-database (10.1) unstable; urgency=low
408 * Make sipb-xen-database-tables safer (don't default to drop_all)
410 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Mon, 12 Nov 2007 04:39:59 -0500
412 sipb-xen-database (10) unstable; urgency=low
414 * Added a machine_access table for cached ACLs
416 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Mon, 12 Nov 2007 04:24:35 -0500
418 sipb-xen-database (9.0) unstable; urgency=low
422 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Wed, 10 Oct 2007 00:17:20 -0400
424 sipb-xen-database (9) unstable; urgency=low
426 * Add administrator column and backrefs to machine.
428 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Wed, 10 Oct 2007 00:11:47 -0400
430 sipb-xen-database (8) gutsy; urgency=low
432 * Prepend d_ to database VMs.
434 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Tue, 9 Oct 2007 02:35:51 -0400
436 sipb-xen-database (7.00002) gutsy; urgency=low
438 * Actually import re.
440 -- Anders Kaseorg <andersk@mit.edu> Sun, 07 Oct 2007 04:34:07 -0400
442 sipb-xen-database (7.00001) gutsy; urgency=low
446 -- Anders Kaseorg <andersk@mit.edu> Sun, 07 Oct 2007 03:40:25 -0400
448 sipb-xen-database (7) unstable; urgency=low
450 * nics primary key should be mac address, not hostname.
451 * Make ip unique, and constructor for nics.
452 * Add a table for boot CDs.
453 * Add cdrom_image parameter.
454 * Regex sanity checking.
456 -- Anders Kaseorg <andersk@mit.edu> Sun, 07 Oct 2007 03:18:30 -0400
458 sipb-xen-database (6) unstable; urgency=low
460 * Adding a script to create lvm volumes
462 -- Nelson Elhage <nelhage@mit.edu> Sat, 22 Sep 2007 13:59:36 -0400
464 sipb-xen-database (5) unstable; urgency=low
466 * Change the host from sipb-vm-1 to sipb-xen-dev
468 -- Nelson Elhage <nelhage@mit.edu> Sat, 8 Sep 2007 16:16:07 -0400
470 sipb-xen-database (4) unstable; urgency=low
472 * Add script=vif-sipbroute to our vif lines
474 -- Nelson Elhage <nelhage@mit.edu> Fri, 24 Aug 2007 22:07:18 -0400
476 sipb-xen-database (3) unstable; urgency=low
478 * Add a connect() line to sipb-database
479 * Fix some other bugs in sipb-database
481 -- Nelson Elhage <nelhage@mit.edu> Sun, 19 Aug 2007 19:40:08 -0400
483 sipb-xen-database (2) unstable; urgency=low
485 * Fix the postinit and prerm scripts to create a sipb-xen user
487 -- Nelson Elhage <nelhage@mit.edu> Thu, 16 Aug 2007 16:27:36 -0400
489 sipb-xen-database (1) unstable; urgency=low
493 -- Nelson Elhage <nelhage@mit.edu> Sun, 15 Jul 2007 16:01:16 -0400