1 invirt-database (0.1.8) unstable; urgency=low
4 * Added Record superclass for models, handling __repr__ consistently.
7 invirt.database.record, .owner:
8 * use self.c rather than self.__dict__ for SQLAlchemy fields
9 * make Record._ignore, Owner.get* classmethods
10 * fold FormattableRecord, NullableRecord into Record
11 * shorten types in lists to __name__
14 * refactor code that sets values
15 * print full help on no arguments
20 -- Greg Price <price@mit.edu> Fri, 27 Feb 2009 02:29:29 -0500
22 invirt-database (0.1.7) unstable; urgency=low
24 * Disk quotas are measured in gibibytes.
25 * Rename invirt-setquotas to invirt-quota.
26 * Be explicit about units in invirt-quota.
28 -- Evan Broder <broder@mit.edu> Tue, 17 Feb 2009 04:29:20 -0500
30 invirt-database (0.1.6) unstable; urgency=low
32 * Move invirt-setquotas into this package.
33 * Don't explicitly initialize the values for each quota when creating a
36 -- Evan Broder <broder@mit.edu> Tue, 17 Feb 2009 03:44:20 -0500
38 invirt-database (0.1.5) unstable; urgency=low
40 * Make the default values on the owners table explicit
41 (Note: This is a NOOP, since a nullable field with no otherwise
42 specified default defaults to NULL)
44 -- Evan Broder <broder@mit.edu> Tue, 17 Feb 2009 03:36:47 -0500
46 invirt-database (0.1.4) unstable; urgency=low
50 -- Peter A. Iannucci <iannucci@mit.edu> Tue, 17 Feb 2009 02:59:14 -0500
52 invirt-database (0.1.3) unstable; urgency=low
54 * Added owner table to database with ram, disk, and VM quotas
55 * Refactored Owner class into separate sourcefile
57 -- Peter A. Iannucci <iannucci@mit.edu> Tue, 17 Feb 2009 01:31:53 -0500
59 invirt-database (0.1.2) unstable; urgency=low
61 * Clean up the .egg-info directory from the right place.
63 -- Evan Broder <broder@mit.edu> Mon, 05 Jan 2009 23:50:47 -0500
65 invirt-database (0.1.1) unstable; urgency=low
67 * Correct a lintian spelling warning.
69 -- Evan Broder <broder@mit.edu> Mon, 05 Jan 2009 23:40:44 -0500
71 invirt-database (0.1.0) unstable; urgency=low
73 * Turn on lazy loading for all tables
75 -- Evan Broder <broder@mit.edu> Mon, 17 Nov 2008 21:57:35 -0500
77 invirt-database (0.0.6) unstable; urgency=low
79 * Let machines.administrator be NULL
81 -- Evan Broder <broder@mit.edu> Mon, 17 Nov 2008 13:41:48 -0500
83 invirt-database (0.0.5) unstable; urgency=low
85 * Add an architecture field to the autoinstaller table
87 -- Evan Broder <broder@mit.edu> Mon, 17 Nov 2008 12:18:02 -0500
89 invirt-database (0.0.3) unstable; urgency=low
91 * Add attributes to the ORM objects to connect mirrors and cdroms
93 -- Evan Broder <broder@mit.edu> Tue, 28 Oct 2008 03:16:18 -0400
95 invirt-database (0.0.2) unstable; urgency=low
97 * Export mirrors_table and Mirrors from invirt.database.models
99 -- Evan Broder <broder@mit.edu> Tue, 28 Oct 2008 03:04:54 -0400
101 invirt-database (0.0.1) unstable; urgency=low
103 * sipb-xen-database-common -> invirt-database
104 * sipb-xen-database-server -> invirt-database-server (a separate source package)
105 * sipb-xen-database-client -> invirt-xen-config
107 -- Evan Broder <broder@mit.edu> Sat, 25 Oct 2008 19:22:46 -0400
109 sipb-xen-database (10.36.1) unstable; urgency=low
111 * Typo in the new tables
113 -- Evan Broder <broder@mit.edu> Sat, 25 Oct 2008 15:01:47 -0400
115 sipb-xen-database (10.36) unstable; urgency=low
117 * Kill the remnants of the sipb_xen_database package
118 * Add the CDROM mirrors table
120 -- Evan Broder <broder@mit.edu> Sat, 25 Oct 2008 14:48:32 -0400
122 sipb-xen-database (10.35) unstable; urgency=low
124 * Shorten initscript with spiffy new library from sipb-xen-base
126 -- Greg Price <price@mit.edu> Fri, 24 Oct 2008 07:25:56 -0400
128 sipb-xen-database (10.34) unstable; urgency=low
130 * yet another new-sqlalchemy fix, this one post-0.4.2
132 -- Greg Price <price@mit.edu> Thu, 23 Oct 2008 23:02:46 -0400
134 sipb-xen-database (10.33) unstable; urgency=low
136 * Catch calls to restart Postgres and translate them into a sequential
139 -- Evan Broder <broder@mit.edu> Mon, 20 Oct 2008 13:05:29 -0400
141 sipb-xen-database (10.32) unstable; urgency=low
143 * invirt.database.clear_cache should actually do something
145 -- Evan Broder <broder@mit.edu> Sun, 19 Oct 2008 02:02:37 -0400
147 sipb-xen-database (10.31) unstable; urgency=low
149 * Database-managed VMs should never even think about bridging
151 -- Evan Broder <broder@mit.edu> Sun, 19 Oct 2008 01:46:45 -0400
153 sipb-xen-database (10.30.4) unstable; urgency=low
155 * Fix a typo in the CDROM image path
157 -- Evan Broder <broder@mit.edu> Wed, 15 Oct 2008 13:21:10 -0400
159 sipb-xen-database (10.30.3) unstable; urgency=low
161 * fix copy-paste errors in initscript: this is database, not console
162 * fix "typo" in initscript for package name printed in logs
164 -- Greg Price <price@mit.edu> Sat, 11 Oct 2008 17:50:11 -0700
166 sipb-xen-database (10.30.2) unstable; urgency=low
168 * Fix a typo in the CDROM lookup in sipb-database
170 -- Evan Broder <broder@mit.edu> Sat, 11 Oct 2008 19:17:05 -0400
172 sipb-xen-database (10.30.1) unstable; urgency=low
174 * Don't strip quotes that won't be there
176 -- Evan Broder <broder@mit.edu> Fri, 10 Oct 2008 01:48:48 -0400
178 sipb-xen-database (10.30) unstable; urgency=low
180 * Look for CD images in /dev/xenvg/image_* and validate image name from
182 * Pass the installer arguments unaltered to the kernel, matching the
185 -- Evan Broder <broder@mit.edu> Thu, 09 Oct 2008 02:09:42 -0400
187 sipb-xen-database (10.29) unstable; urgency=low
189 * Some fixes in the sipb-database script
191 -- Evan Broder <broder@mit.edu> Mon, 06 Oct 2008 18:55:24 -0400
193 sipb-xen-database (10.28) unstable; urgency=low
195 * Re-establish the database connection if the server goes AWOL
197 -- Evan Broder <broder@mit.edu> Sat, 04 Oct 2008 23:19:59 -0400
199 sipb-xen-database (10.27) unstable; urgency=low
201 * Update sipb-database to work with newer SQLAlchemy and Xen
203 -- Evan Broder <broder@mit.edu> Fri, 03 Oct 2008 20:08:16 -0400
205 sipb-xen-database (10.26.1) unstable; urgency=low
207 * We want autoflush off, too
209 -- Evan Broder <broder@mit.edu> Fri, 03 Oct 2008 19:22:12 -0400
211 sipb-xen-database (10.26) unstable; urgency=low
213 * Disable transactions by default
215 -- Evan Broder <broder@mit.edu> Thu, 02 Oct 2008 19:40:34 -0400
217 sipb-xen-database (10.25) unstable; urgency=low
219 * add remote and console to pg_hba.conf template
220 * fix init script so it works
221 * port more code to sqlalchemy 0.4
223 -- Greg Price <price@mit.edu> Wed, 01 Oct 2008 19:30:26 -0400
225 sipb-xen-database (10.24) unstable; urgency=low
227 * Update postgresql.conf for Hardy
229 -- Evan Broder <broder@mit.edu> Wed, 01 Oct 2008 03:12:36 -0400
231 sipb-xen-database (10.23) unstable; urgency=low
233 * switch to postgresql 8.3, as 8.1 isn't in hardy
235 -- Greg Price <price@mit.edu> Wed, 01 Oct 2008 02:09:43 -0400
237 sipb-xen-database (10.22) unstable; urgency=low
239 * depend on postgresql without specifying old version 8.1
241 -- Greg Price <price@mit.edu> Wed, 01 Oct 2008 01:55:49 -0400
243 sipb-xen-database (10.21) unstable; urgency=low
247 -- Greg Price <price@mit.edu> Tue, 30 Sep 2008 23:50:25 -0400
249 sipb-xen-database (10.20) hardy; urgency=low
251 * port to sqlalchemy-0.4, which cuts out some newly deprecated
252 interfaces and allowed some still-present interfaces to bitrot
254 -- Greg Price <price@mit.edu> Mon, 29 Sep 2008 06:06:21 +0000
256 sipb-xen-database (10.19) unstable; urgency=low
258 * Generate config files for pg_hba.conf
259 * replace postgresql.conf
261 -- Sam Hartman <hartmans@xvm.mit.edu> Mon, 25 Aug 2008 00:38:21 +0000
263 sipb-xen-database (10.18) unstable; urgency=low
265 * add 'adminable' column to machines; for selectively, temporarily,
266 enabling admin mode on a machine
268 -- Greg Price <price@mit.edu> Wed, 6 Aug 2008 01:02:59 -0400
270 sipb-xen-database (10.17) unstable; urgency=low
272 * pull IP gateway, network from config
273 * configurabilization complete!
275 -- Greg Price <price@mit.edu> Sun, 3 Aug 2008 01:16:53 -0400
277 sipb-xen-database (10.16) unstable; urgency=low
279 in sipb-xen-database-tables:
280 * use invirt.database, and take default db uri
282 -- Greg Price <price@mit.edu> Sun, 3 Aug 2008 00:51:32 -0400
284 sipb-xen-database (10.15) unstable; urgency=low
286 in /etc/xen/database:
287 * uncommitted changes on black-mesa
288 * sipb_xen_database -> invirt.database
292 * get default db uri from invirt.config
294 -- Greg Price <price@mit.edu> Sun, 3 Aug 2008 00:26:46 -0400
296 sipb-xen-database (10.14) unstable; urgency=low
298 * Rename sipb_xen_database -> invirt.database,
299 keeping old name too for now, for compatibility.
301 -- Greg Price <price@mit.edu> Sat, 2 Aug 2008 23:19:18 -0400
303 sipb-xen-database (10.13) unstable; urgency=low
305 * Modify autoinstalls table to specify distribution/mirror.
307 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Sat, 21 Jun 2008 21:25:21 -0400
309 sipb-xen-database (10.12) unstable; urgency=low
311 * Add a description field.
313 -- Anders Kaseorg <andersk@mit.edu> Wed, 18 Jun 2008 03:52:49 -0400
315 sipb-xen-database (10.11) unstable; urgency=low
317 * Specify ON DELETE CASCADE
319 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 06 Jun 2008 12:25:35 -0400
321 sipb-xen-database (10.10) unstable; urgency=low
323 * Make machine.acl a private relation.
325 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 06 Jun 2008 12:03:09 -0400
327 sipb-xen-database (10.9) unstable; urgency=low
329 * Eager loading of relations for better performance.
331 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Mon, 02 Jun 2008 01:39:11 -0400
333 sipb-xen-database (10.8) unstable; urgency=low
335 * Configure serial console on boot
337 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Thu, 1 May 2008 20:21:25 -0400
339 sipb-xen-database (10.7) unstable; urgency=low
341 * Depend on psql client in -client package.
343 -- Greg Price <price@mit.edu> Sat, 26 Apr 2008 21:06:41 -0400
345 sipb-xen-database (10.6) unstable; urgency=low
347 * Support autoinstalls table.
349 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Mon, 21 Apr 2008 22:34:46 -0400
351 sipb-xen-database (10.5) unstable; urgency=low
353 * Enable USB tablet device in guests.
355 -- Anders Kaseorg <andersk@mit.edu> Mon, 21 Apr 2008 17:39:59 -0400
357 sipb-xen-database (10.4.1) unstable; urgency=low
359 * Actually export the cache clearing function.
361 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 28 Mar 2008 21:18:01 -0400
363 sipb-xen-database (10.4) unstable; urgency=low
365 * Ubuntu's dch sucks.
367 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Fri, 28 Mar 2008 20:43:42 -0400
369 sipb-xen-database (10.3ubuntu1) gutsy; urgency=low
371 * Expose a function for clearing the cache.
373 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 28 Mar 2008 20:31:06 -0400
375 sipb-xen-database (10.3) unstable; urgency=low
377 * Use 'acl', not 'users', for the reference to the machine_access table.
379 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Thu, 24 Jan 2008 17:23:33 -0500
381 sipb-xen-database (10.2) unstable; urgency=low
383 * Add MachineAccess to __all__ so it can be imported
384 * Remove unnecessary constructors for database objects
386 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Mon, 12 Nov 2007 04:53:47 -0500
388 sipb-xen-database (10.1) unstable; urgency=low
390 * Make sipb-xen-database-tables safer (don't default to drop_all)
392 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Mon, 12 Nov 2007 04:39:59 -0500
394 sipb-xen-database (10) unstable; urgency=low
396 * Added a machine_access table for cached ACLs
398 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Mon, 12 Nov 2007 04:24:35 -0500
400 sipb-xen-database (9.0) unstable; urgency=low
404 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Wed, 10 Oct 2007 00:17:20 -0400
406 sipb-xen-database (9) unstable; urgency=low
408 * Add administrator column and backrefs to machine.
410 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Wed, 10 Oct 2007 00:11:47 -0400
412 sipb-xen-database (8) gutsy; urgency=low
414 * Prepend d_ to database VMs.
416 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Tue, 9 Oct 2007 02:35:51 -0400
418 sipb-xen-database (7.00002) gutsy; urgency=low
420 * Actually import re.
422 -- Anders Kaseorg <andersk@mit.edu> Sun, 07 Oct 2007 04:34:07 -0400
424 sipb-xen-database (7.00001) gutsy; urgency=low
428 -- Anders Kaseorg <andersk@mit.edu> Sun, 07 Oct 2007 03:40:25 -0400
430 sipb-xen-database (7) unstable; urgency=low
432 * nics primary key should be mac address, not hostname.
433 * Make ip unique, and constructor for nics.
434 * Add a table for boot CDs.
435 * Add cdrom_image parameter.
436 * Regex sanity checking.
438 -- Anders Kaseorg <andersk@mit.edu> Sun, 07 Oct 2007 03:18:30 -0400
440 sipb-xen-database (6) unstable; urgency=low
442 * Adding a script to create lvm volumes
444 -- Nelson Elhage <nelhage@mit.edu> Sat, 22 Sep 2007 13:59:36 -0400
446 sipb-xen-database (5) unstable; urgency=low
448 * Change the host from sipb-vm-1 to sipb-xen-dev
450 -- Nelson Elhage <nelhage@mit.edu> Sat, 8 Sep 2007 16:16:07 -0400
452 sipb-xen-database (4) unstable; urgency=low
454 * Add script=vif-sipbroute to our vif lines
456 -- Nelson Elhage <nelhage@mit.edu> Fri, 24 Aug 2007 22:07:18 -0400
458 sipb-xen-database (3) unstable; urgency=low
460 * Add a connect() line to sipb-database
461 * Fix some other bugs in sipb-database
463 -- Nelson Elhage <nelhage@mit.edu> Sun, 19 Aug 2007 19:40:08 -0400
465 sipb-xen-database (2) unstable; urgency=low
467 * Fix the postinit and prerm scripts to create a sipb-xen user
469 -- Nelson Elhage <nelhage@mit.edu> Thu, 16 Aug 2007 16:27:36 -0400
471 sipb-xen-database (1) unstable; urgency=low
475 -- Nelson Elhage <nelhage@mit.edu> Sun, 15 Jul 2007 16:01:16 -0400