1 invirt-database (0.1.9) unstable; urgency=low
3 * Make get*Quotas idempotent
4 * Move Owner import so that Owner can access session in
7 -- Quentin Smith <quentin@mit.edu> Fri, 27 Feb 2009 14:17:53 -0500
9 invirt-database (0.1.8) unstable; urgency=low
12 * Added Record superclass for models, handling __repr__ consistently.
15 invirt.database.record, .owner:
16 * use self.c rather than self.__dict__ for SQLAlchemy fields
17 * make Record._ignore, Owner.get* classmethods
18 * fold FormattableRecord, NullableRecord into Record
19 * shorten types in lists to __name__
22 * refactor code that sets values
23 * print full help on no arguments
29 * Add "reusable" column for nics, to avoid reusing addresses that are
32 -- Quentin Smith <quentin@mit.edu> Fri, 27 Feb 2009 11:51:39 -0500
34 invirt-database (0.1.7) unstable; urgency=low
36 * Disk quotas are measured in gibibytes.
37 * Rename invirt-setquotas to invirt-quota.
38 * Be explicit about units in invirt-quota.
40 -- Evan Broder <broder@mit.edu> Tue, 17 Feb 2009 04:29:20 -0500
42 invirt-database (0.1.6) unstable; urgency=low
44 * Move invirt-setquotas into this package.
45 * Don't explicitly initialize the values for each quota when creating a
48 -- Evan Broder <broder@mit.edu> Tue, 17 Feb 2009 03:44:20 -0500
50 invirt-database (0.1.5) unstable; urgency=low
52 * Make the default values on the owners table explicit
53 (Note: This is a NOOP, since a nullable field with no otherwise
54 specified default defaults to NULL)
56 -- Evan Broder <broder@mit.edu> Tue, 17 Feb 2009 03:36:47 -0500
58 invirt-database (0.1.4) unstable; urgency=low
62 -- Peter A. Iannucci <iannucci@mit.edu> Tue, 17 Feb 2009 02:59:14 -0500
64 invirt-database (0.1.3) unstable; urgency=low
66 * Added owner table to database with ram, disk, and VM quotas
67 * Refactored Owner class into separate sourcefile
69 -- Peter A. Iannucci <iannucci@mit.edu> Tue, 17 Feb 2009 01:31:53 -0500
71 invirt-database (0.1.2) unstable; urgency=low
73 * Clean up the .egg-info directory from the right place.
75 -- Evan Broder <broder@mit.edu> Mon, 05 Jan 2009 23:50:47 -0500
77 invirt-database (0.1.1) unstable; urgency=low
79 * Correct a lintian spelling warning.
81 -- Evan Broder <broder@mit.edu> Mon, 05 Jan 2009 23:40:44 -0500
83 invirt-database (0.1.0) unstable; urgency=low
85 * Turn on lazy loading for all tables
87 -- Evan Broder <broder@mit.edu> Mon, 17 Nov 2008 21:57:35 -0500
89 invirt-database (0.0.6) unstable; urgency=low
91 * Let machines.administrator be NULL
93 -- Evan Broder <broder@mit.edu> Mon, 17 Nov 2008 13:41:48 -0500
95 invirt-database (0.0.5) unstable; urgency=low
97 * Add an architecture field to the autoinstaller table
99 -- Evan Broder <broder@mit.edu> Mon, 17 Nov 2008 12:18:02 -0500
101 invirt-database (0.0.3) unstable; urgency=low
103 * Add attributes to the ORM objects to connect mirrors and cdroms
105 -- Evan Broder <broder@mit.edu> Tue, 28 Oct 2008 03:16:18 -0400
107 invirt-database (0.0.2) unstable; urgency=low
109 * Export mirrors_table and Mirrors from invirt.database.models
111 -- Evan Broder <broder@mit.edu> Tue, 28 Oct 2008 03:04:54 -0400
113 invirt-database (0.0.1) unstable; urgency=low
115 * sipb-xen-database-common -> invirt-database
116 * sipb-xen-database-server -> invirt-database-server (a separate source package)
117 * sipb-xen-database-client -> invirt-xen-config
119 -- Evan Broder <broder@mit.edu> Sat, 25 Oct 2008 19:22:46 -0400
121 sipb-xen-database (10.36.1) unstable; urgency=low
123 * Typo in the new tables
125 -- Evan Broder <broder@mit.edu> Sat, 25 Oct 2008 15:01:47 -0400
127 sipb-xen-database (10.36) unstable; urgency=low
129 * Kill the remnants of the sipb_xen_database package
130 * Add the CDROM mirrors table
132 -- Evan Broder <broder@mit.edu> Sat, 25 Oct 2008 14:48:32 -0400
134 sipb-xen-database (10.35) unstable; urgency=low
136 * Shorten initscript with spiffy new library from sipb-xen-base
138 -- Greg Price <price@mit.edu> Fri, 24 Oct 2008 07:25:56 -0400
140 sipb-xen-database (10.34) unstable; urgency=low
142 * yet another new-sqlalchemy fix, this one post-0.4.2
144 -- Greg Price <price@mit.edu> Thu, 23 Oct 2008 23:02:46 -0400
146 sipb-xen-database (10.33) unstable; urgency=low
148 * Catch calls to restart Postgres and translate them into a sequential
151 -- Evan Broder <broder@mit.edu> Mon, 20 Oct 2008 13:05:29 -0400
153 sipb-xen-database (10.32) unstable; urgency=low
155 * invirt.database.clear_cache should actually do something
157 -- Evan Broder <broder@mit.edu> Sun, 19 Oct 2008 02:02:37 -0400
159 sipb-xen-database (10.31) unstable; urgency=low
161 * Database-managed VMs should never even think about bridging
163 -- Evan Broder <broder@mit.edu> Sun, 19 Oct 2008 01:46:45 -0400
165 sipb-xen-database (10.30.4) unstable; urgency=low
167 * Fix a typo in the CDROM image path
169 -- Evan Broder <broder@mit.edu> Wed, 15 Oct 2008 13:21:10 -0400
171 sipb-xen-database (10.30.3) unstable; urgency=low
173 * fix copy-paste errors in initscript: this is database, not console
174 * fix "typo" in initscript for package name printed in logs
176 -- Greg Price <price@mit.edu> Sat, 11 Oct 2008 17:50:11 -0700
178 sipb-xen-database (10.30.2) unstable; urgency=low
180 * Fix a typo in the CDROM lookup in sipb-database
182 -- Evan Broder <broder@mit.edu> Sat, 11 Oct 2008 19:17:05 -0400
184 sipb-xen-database (10.30.1) unstable; urgency=low
186 * Don't strip quotes that won't be there
188 -- Evan Broder <broder@mit.edu> Fri, 10 Oct 2008 01:48:48 -0400
190 sipb-xen-database (10.30) unstable; urgency=low
192 * Look for CD images in /dev/xenvg/image_* and validate image name from
194 * Pass the installer arguments unaltered to the kernel, matching the
197 -- Evan Broder <broder@mit.edu> Thu, 09 Oct 2008 02:09:42 -0400
199 sipb-xen-database (10.29) unstable; urgency=low
201 * Some fixes in the sipb-database script
203 -- Evan Broder <broder@mit.edu> Mon, 06 Oct 2008 18:55:24 -0400
205 sipb-xen-database (10.28) unstable; urgency=low
207 * Re-establish the database connection if the server goes AWOL
209 -- Evan Broder <broder@mit.edu> Sat, 04 Oct 2008 23:19:59 -0400
211 sipb-xen-database (10.27) unstable; urgency=low
213 * Update sipb-database to work with newer SQLAlchemy and Xen
215 -- Evan Broder <broder@mit.edu> Fri, 03 Oct 2008 20:08:16 -0400
217 sipb-xen-database (10.26.1) unstable; urgency=low
219 * We want autoflush off, too
221 -- Evan Broder <broder@mit.edu> Fri, 03 Oct 2008 19:22:12 -0400
223 sipb-xen-database (10.26) unstable; urgency=low
225 * Disable transactions by default
227 -- Evan Broder <broder@mit.edu> Thu, 02 Oct 2008 19:40:34 -0400
229 sipb-xen-database (10.25) unstable; urgency=low
231 * add remote and console to pg_hba.conf template
232 * fix init script so it works
233 * port more code to sqlalchemy 0.4
235 -- Greg Price <price@mit.edu> Wed, 01 Oct 2008 19:30:26 -0400
237 sipb-xen-database (10.24) unstable; urgency=low
239 * Update postgresql.conf for Hardy
241 -- Evan Broder <broder@mit.edu> Wed, 01 Oct 2008 03:12:36 -0400
243 sipb-xen-database (10.23) unstable; urgency=low
245 * switch to postgresql 8.3, as 8.1 isn't in hardy
247 -- Greg Price <price@mit.edu> Wed, 01 Oct 2008 02:09:43 -0400
249 sipb-xen-database (10.22) unstable; urgency=low
251 * depend on postgresql without specifying old version 8.1
253 -- Greg Price <price@mit.edu> Wed, 01 Oct 2008 01:55:49 -0400
255 sipb-xen-database (10.21) unstable; urgency=low
259 -- Greg Price <price@mit.edu> Tue, 30 Sep 2008 23:50:25 -0400
261 sipb-xen-database (10.20) hardy; urgency=low
263 * port to sqlalchemy-0.4, which cuts out some newly deprecated
264 interfaces and allowed some still-present interfaces to bitrot
266 -- Greg Price <price@mit.edu> Mon, 29 Sep 2008 06:06:21 +0000
268 sipb-xen-database (10.19) unstable; urgency=low
270 * Generate config files for pg_hba.conf
271 * replace postgresql.conf
273 -- Sam Hartman <hartmans@xvm.mit.edu> Mon, 25 Aug 2008 00:38:21 +0000
275 sipb-xen-database (10.18) unstable; urgency=low
277 * add 'adminable' column to machines; for selectively, temporarily,
278 enabling admin mode on a machine
280 -- Greg Price <price@mit.edu> Wed, 6 Aug 2008 01:02:59 -0400
282 sipb-xen-database (10.17) unstable; urgency=low
284 * pull IP gateway, network from config
285 * configurabilization complete!
287 -- Greg Price <price@mit.edu> Sun, 3 Aug 2008 01:16:53 -0400
289 sipb-xen-database (10.16) unstable; urgency=low
291 in sipb-xen-database-tables:
292 * use invirt.database, and take default db uri
294 -- Greg Price <price@mit.edu> Sun, 3 Aug 2008 00:51:32 -0400
296 sipb-xen-database (10.15) unstable; urgency=low
298 in /etc/xen/database:
299 * uncommitted changes on black-mesa
300 * sipb_xen_database -> invirt.database
304 * get default db uri from invirt.config
306 -- Greg Price <price@mit.edu> Sun, 3 Aug 2008 00:26:46 -0400
308 sipb-xen-database (10.14) unstable; urgency=low
310 * Rename sipb_xen_database -> invirt.database,
311 keeping old name too for now, for compatibility.
313 -- Greg Price <price@mit.edu> Sat, 2 Aug 2008 23:19:18 -0400
315 sipb-xen-database (10.13) unstable; urgency=low
317 * Modify autoinstalls table to specify distribution/mirror.
319 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Sat, 21 Jun 2008 21:25:21 -0400
321 sipb-xen-database (10.12) unstable; urgency=low
323 * Add a description field.
325 -- Anders Kaseorg <andersk@mit.edu> Wed, 18 Jun 2008 03:52:49 -0400
327 sipb-xen-database (10.11) unstable; urgency=low
329 * Specify ON DELETE CASCADE
331 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 06 Jun 2008 12:25:35 -0400
333 sipb-xen-database (10.10) unstable; urgency=low
335 * Make machine.acl a private relation.
337 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 06 Jun 2008 12:03:09 -0400
339 sipb-xen-database (10.9) unstable; urgency=low
341 * Eager loading of relations for better performance.
343 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Mon, 02 Jun 2008 01:39:11 -0400
345 sipb-xen-database (10.8) unstable; urgency=low
347 * Configure serial console on boot
349 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Thu, 1 May 2008 20:21:25 -0400
351 sipb-xen-database (10.7) unstable; urgency=low
353 * Depend on psql client in -client package.
355 -- Greg Price <price@mit.edu> Sat, 26 Apr 2008 21:06:41 -0400
357 sipb-xen-database (10.6) unstable; urgency=low
359 * Support autoinstalls table.
361 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Mon, 21 Apr 2008 22:34:46 -0400
363 sipb-xen-database (10.5) unstable; urgency=low
365 * Enable USB tablet device in guests.
367 -- Anders Kaseorg <andersk@mit.edu> Mon, 21 Apr 2008 17:39:59 -0400
369 sipb-xen-database (10.4.1) unstable; urgency=low
371 * Actually export the cache clearing function.
373 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 28 Mar 2008 21:18:01 -0400
375 sipb-xen-database (10.4) unstable; urgency=low
377 * Ubuntu's dch sucks.
379 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Fri, 28 Mar 2008 20:43:42 -0400
381 sipb-xen-database (10.3ubuntu1) gutsy; urgency=low
383 * Expose a function for clearing the cache.
385 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 28 Mar 2008 20:31:06 -0400
387 sipb-xen-database (10.3) unstable; urgency=low
389 * Use 'acl', not 'users', for the reference to the machine_access table.
391 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Thu, 24 Jan 2008 17:23:33 -0500
393 sipb-xen-database (10.2) unstable; urgency=low
395 * Add MachineAccess to __all__ so it can be imported
396 * Remove unnecessary constructors for database objects
398 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Mon, 12 Nov 2007 04:53:47 -0500
400 sipb-xen-database (10.1) unstable; urgency=low
402 * Make sipb-xen-database-tables safer (don't default to drop_all)
404 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Mon, 12 Nov 2007 04:39:59 -0500
406 sipb-xen-database (10) unstable; urgency=low
408 * Added a machine_access table for cached ACLs
410 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Mon, 12 Nov 2007 04:24:35 -0500
412 sipb-xen-database (9.0) unstable; urgency=low
416 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Wed, 10 Oct 2007 00:17:20 -0400
418 sipb-xen-database (9) unstable; urgency=low
420 * Add administrator column and backrefs to machine.
422 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Wed, 10 Oct 2007 00:11:47 -0400
424 sipb-xen-database (8) gutsy; urgency=low
426 * Prepend d_ to database VMs.
428 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Tue, 9 Oct 2007 02:35:51 -0400
430 sipb-xen-database (7.00002) gutsy; urgency=low
432 * Actually import re.
434 -- Anders Kaseorg <andersk@mit.edu> Sun, 07 Oct 2007 04:34:07 -0400
436 sipb-xen-database (7.00001) gutsy; urgency=low
440 -- Anders Kaseorg <andersk@mit.edu> Sun, 07 Oct 2007 03:40:25 -0400
442 sipb-xen-database (7) unstable; urgency=low
444 * nics primary key should be mac address, not hostname.
445 * Make ip unique, and constructor for nics.
446 * Add a table for boot CDs.
447 * Add cdrom_image parameter.
448 * Regex sanity checking.
450 -- Anders Kaseorg <andersk@mit.edu> Sun, 07 Oct 2007 03:18:30 -0400
452 sipb-xen-database (6) unstable; urgency=low
454 * Adding a script to create lvm volumes
456 -- Nelson Elhage <nelhage@mit.edu> Sat, 22 Sep 2007 13:59:36 -0400
458 sipb-xen-database (5) unstable; urgency=low
460 * Change the host from sipb-vm-1 to sipb-xen-dev
462 -- Nelson Elhage <nelhage@mit.edu> Sat, 8 Sep 2007 16:16:07 -0400
464 sipb-xen-database (4) unstable; urgency=low
466 * Add script=vif-sipbroute to our vif lines
468 -- Nelson Elhage <nelhage@mit.edu> Fri, 24 Aug 2007 22:07:18 -0400
470 sipb-xen-database (3) unstable; urgency=low
472 * Add a connect() line to sipb-database
473 * Fix some other bugs in sipb-database
475 -- Nelson Elhage <nelhage@mit.edu> Sun, 19 Aug 2007 19:40:08 -0400
477 sipb-xen-database (2) unstable; urgency=low
479 * Fix the postinit and prerm scripts to create a sipb-xen user
481 -- Nelson Elhage <nelhage@mit.edu> Thu, 16 Aug 2007 16:27:36 -0400
483 sipb-xen-database (1) unstable; urgency=low
487 -- Nelson Elhage <nelhage@mit.edu> Sun, 15 Jul 2007 16:01:16 -0400