1 invirt-database (0.1.8) unstable; urgency=low
4 * Added Record superclass for models, handling __repr__ consistently.
7 invirt.database.record, .owner:
8 * use self.c rather than self.__dict__ for SQLAlchemy fields
9 * make Record._ignore, Owner.get* classmethods
10 * fold FormattableRecord, NullableRecord into Record
11 * shorten types in lists to __name__
14 * refactor code that sets values
15 * print full help on no arguments
18 -- Greg Price <price@mit.edu> Fri, 27 Feb 2009 02:16:28 -0500
20 invirt-database (0.1.7) unstable; urgency=low
22 * Disk quotas are measured in gibibytes.
23 * Rename invirt-setquotas to invirt-quota.
24 * Be explicit about units in invirt-quota.
26 -- Evan Broder <broder@mit.edu> Tue, 17 Feb 2009 04:29:20 -0500
28 invirt-database (0.1.6) unstable; urgency=low
30 * Move invirt-setquotas into this package.
31 * Don't explicitly initialize the values for each quota when creating a
34 -- Evan Broder <broder@mit.edu> Tue, 17 Feb 2009 03:44:20 -0500
36 invirt-database (0.1.5) unstable; urgency=low
38 * Make the default values on the owners table explicit
39 (Note: This is a NOOP, since a nullable field with no otherwise
40 specified default defaults to NULL)
42 -- Evan Broder <broder@mit.edu> Tue, 17 Feb 2009 03:36:47 -0500
44 invirt-database (0.1.4) unstable; urgency=low
48 -- Peter A. Iannucci <iannucci@mit.edu> Tue, 17 Feb 2009 02:59:14 -0500
50 invirt-database (0.1.3) unstable; urgency=low
52 * Added owner table to database with ram, disk, and VM quotas
53 * Refactored Owner class into separate sourcefile
55 -- Peter A. Iannucci <iannucci@mit.edu> Tue, 17 Feb 2009 01:31:53 -0500
57 invirt-database (0.1.2) unstable; urgency=low
59 * Clean up the .egg-info directory from the right place.
61 -- Evan Broder <broder@mit.edu> Mon, 05 Jan 2009 23:50:47 -0500
63 invirt-database (0.1.1) unstable; urgency=low
65 * Correct a lintian spelling warning.
67 -- Evan Broder <broder@mit.edu> Mon, 05 Jan 2009 23:40:44 -0500
69 invirt-database (0.1.0) unstable; urgency=low
71 * Turn on lazy loading for all tables
73 -- Evan Broder <broder@mit.edu> Mon, 17 Nov 2008 21:57:35 -0500
75 invirt-database (0.0.6) unstable; urgency=low
77 * Let machines.administrator be NULL
79 -- Evan Broder <broder@mit.edu> Mon, 17 Nov 2008 13:41:48 -0500
81 invirt-database (0.0.5) unstable; urgency=low
83 * Add an architecture field to the autoinstaller table
85 -- Evan Broder <broder@mit.edu> Mon, 17 Nov 2008 12:18:02 -0500
87 invirt-database (0.0.3) unstable; urgency=low
89 * Add attributes to the ORM objects to connect mirrors and cdroms
91 -- Evan Broder <broder@mit.edu> Tue, 28 Oct 2008 03:16:18 -0400
93 invirt-database (0.0.2) unstable; urgency=low
95 * Export mirrors_table and Mirrors from invirt.database.models
97 -- Evan Broder <broder@mit.edu> Tue, 28 Oct 2008 03:04:54 -0400
99 invirt-database (0.0.1) unstable; urgency=low
101 * sipb-xen-database-common -> invirt-database
102 * sipb-xen-database-server -> invirt-database-server (a separate source package)
103 * sipb-xen-database-client -> invirt-xen-config
105 -- Evan Broder <broder@mit.edu> Sat, 25 Oct 2008 19:22:46 -0400
107 sipb-xen-database (10.36.1) unstable; urgency=low
109 * Typo in the new tables
111 -- Evan Broder <broder@mit.edu> Sat, 25 Oct 2008 15:01:47 -0400
113 sipb-xen-database (10.36) unstable; urgency=low
115 * Kill the remnants of the sipb_xen_database package
116 * Add the CDROM mirrors table
118 -- Evan Broder <broder@mit.edu> Sat, 25 Oct 2008 14:48:32 -0400
120 sipb-xen-database (10.35) unstable; urgency=low
122 * Shorten initscript with spiffy new library from sipb-xen-base
124 -- Greg Price <price@mit.edu> Fri, 24 Oct 2008 07:25:56 -0400
126 sipb-xen-database (10.34) unstable; urgency=low
128 * yet another new-sqlalchemy fix, this one post-0.4.2
130 -- Greg Price <price@mit.edu> Thu, 23 Oct 2008 23:02:46 -0400
132 sipb-xen-database (10.33) unstable; urgency=low
134 * Catch calls to restart Postgres and translate them into a sequential
137 -- Evan Broder <broder@mit.edu> Mon, 20 Oct 2008 13:05:29 -0400
139 sipb-xen-database (10.32) unstable; urgency=low
141 * invirt.database.clear_cache should actually do something
143 -- Evan Broder <broder@mit.edu> Sun, 19 Oct 2008 02:02:37 -0400
145 sipb-xen-database (10.31) unstable; urgency=low
147 * Database-managed VMs should never even think about bridging
149 -- Evan Broder <broder@mit.edu> Sun, 19 Oct 2008 01:46:45 -0400
151 sipb-xen-database (10.30.4) unstable; urgency=low
153 * Fix a typo in the CDROM image path
155 -- Evan Broder <broder@mit.edu> Wed, 15 Oct 2008 13:21:10 -0400
157 sipb-xen-database (10.30.3) unstable; urgency=low
159 * fix copy-paste errors in initscript: this is database, not console
160 * fix "typo" in initscript for package name printed in logs
162 -- Greg Price <price@mit.edu> Sat, 11 Oct 2008 17:50:11 -0700
164 sipb-xen-database (10.30.2) unstable; urgency=low
166 * Fix a typo in the CDROM lookup in sipb-database
168 -- Evan Broder <broder@mit.edu> Sat, 11 Oct 2008 19:17:05 -0400
170 sipb-xen-database (10.30.1) unstable; urgency=low
172 * Don't strip quotes that won't be there
174 -- Evan Broder <broder@mit.edu> Fri, 10 Oct 2008 01:48:48 -0400
176 sipb-xen-database (10.30) unstable; urgency=low
178 * Look for CD images in /dev/xenvg/image_* and validate image name from
180 * Pass the installer arguments unaltered to the kernel, matching the
183 -- Evan Broder <broder@mit.edu> Thu, 09 Oct 2008 02:09:42 -0400
185 sipb-xen-database (10.29) unstable; urgency=low
187 * Some fixes in the sipb-database script
189 -- Evan Broder <broder@mit.edu> Mon, 06 Oct 2008 18:55:24 -0400
191 sipb-xen-database (10.28) unstable; urgency=low
193 * Re-establish the database connection if the server goes AWOL
195 -- Evan Broder <broder@mit.edu> Sat, 04 Oct 2008 23:19:59 -0400
197 sipb-xen-database (10.27) unstable; urgency=low
199 * Update sipb-database to work with newer SQLAlchemy and Xen
201 -- Evan Broder <broder@mit.edu> Fri, 03 Oct 2008 20:08:16 -0400
203 sipb-xen-database (10.26.1) unstable; urgency=low
205 * We want autoflush off, too
207 -- Evan Broder <broder@mit.edu> Fri, 03 Oct 2008 19:22:12 -0400
209 sipb-xen-database (10.26) unstable; urgency=low
211 * Disable transactions by default
213 -- Evan Broder <broder@mit.edu> Thu, 02 Oct 2008 19:40:34 -0400
215 sipb-xen-database (10.25) unstable; urgency=low
217 * add remote and console to pg_hba.conf template
218 * fix init script so it works
219 * port more code to sqlalchemy 0.4
221 -- Greg Price <price@mit.edu> Wed, 01 Oct 2008 19:30:26 -0400
223 sipb-xen-database (10.24) unstable; urgency=low
225 * Update postgresql.conf for Hardy
227 -- Evan Broder <broder@mit.edu> Wed, 01 Oct 2008 03:12:36 -0400
229 sipb-xen-database (10.23) unstable; urgency=low
231 * switch to postgresql 8.3, as 8.1 isn't in hardy
233 -- Greg Price <price@mit.edu> Wed, 01 Oct 2008 02:09:43 -0400
235 sipb-xen-database (10.22) unstable; urgency=low
237 * depend on postgresql without specifying old version 8.1
239 -- Greg Price <price@mit.edu> Wed, 01 Oct 2008 01:55:49 -0400
241 sipb-xen-database (10.21) unstable; urgency=low
245 -- Greg Price <price@mit.edu> Tue, 30 Sep 2008 23:50:25 -0400
247 sipb-xen-database (10.20) hardy; urgency=low
249 * port to sqlalchemy-0.4, which cuts out some newly deprecated
250 interfaces and allowed some still-present interfaces to bitrot
252 -- Greg Price <price@mit.edu> Mon, 29 Sep 2008 06:06:21 +0000
254 sipb-xen-database (10.19) unstable; urgency=low
256 * Generate config files for pg_hba.conf
257 * replace postgresql.conf
259 -- Sam Hartman <hartmans@xvm.mit.edu> Mon, 25 Aug 2008 00:38:21 +0000
261 sipb-xen-database (10.18) unstable; urgency=low
263 * add 'adminable' column to machines; for selectively, temporarily,
264 enabling admin mode on a machine
266 -- Greg Price <price@mit.edu> Wed, 6 Aug 2008 01:02:59 -0400
268 sipb-xen-database (10.17) unstable; urgency=low
270 * pull IP gateway, network from config
271 * configurabilization complete!
273 -- Greg Price <price@mit.edu> Sun, 3 Aug 2008 01:16:53 -0400
275 sipb-xen-database (10.16) unstable; urgency=low
277 in sipb-xen-database-tables:
278 * use invirt.database, and take default db uri
280 -- Greg Price <price@mit.edu> Sun, 3 Aug 2008 00:51:32 -0400
282 sipb-xen-database (10.15) unstable; urgency=low
284 in /etc/xen/database:
285 * uncommitted changes on black-mesa
286 * sipb_xen_database -> invirt.database
290 * get default db uri from invirt.config
292 -- Greg Price <price@mit.edu> Sun, 3 Aug 2008 00:26:46 -0400
294 sipb-xen-database (10.14) unstable; urgency=low
296 * Rename sipb_xen_database -> invirt.database,
297 keeping old name too for now, for compatibility.
299 -- Greg Price <price@mit.edu> Sat, 2 Aug 2008 23:19:18 -0400
301 sipb-xen-database (10.13) unstable; urgency=low
303 * Modify autoinstalls table to specify distribution/mirror.
305 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Sat, 21 Jun 2008 21:25:21 -0400
307 sipb-xen-database (10.12) unstable; urgency=low
309 * Add a description field.
311 -- Anders Kaseorg <andersk@mit.edu> Wed, 18 Jun 2008 03:52:49 -0400
313 sipb-xen-database (10.11) unstable; urgency=low
315 * Specify ON DELETE CASCADE
317 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 06 Jun 2008 12:25:35 -0400
319 sipb-xen-database (10.10) unstable; urgency=low
321 * Make machine.acl a private relation.
323 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 06 Jun 2008 12:03:09 -0400
325 sipb-xen-database (10.9) unstable; urgency=low
327 * Eager loading of relations for better performance.
329 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Mon, 02 Jun 2008 01:39:11 -0400
331 sipb-xen-database (10.8) unstable; urgency=low
333 * Configure serial console on boot
335 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Thu, 1 May 2008 20:21:25 -0400
337 sipb-xen-database (10.7) unstable; urgency=low
339 * Depend on psql client in -client package.
341 -- Greg Price <price@mit.edu> Sat, 26 Apr 2008 21:06:41 -0400
343 sipb-xen-database (10.6) unstable; urgency=low
345 * Support autoinstalls table.
347 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Mon, 21 Apr 2008 22:34:46 -0400
349 sipb-xen-database (10.5) unstable; urgency=low
351 * Enable USB tablet device in guests.
353 -- Anders Kaseorg <andersk@mit.edu> Mon, 21 Apr 2008 17:39:59 -0400
355 sipb-xen-database (10.4.1) unstable; urgency=low
357 * Actually export the cache clearing function.
359 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 28 Mar 2008 21:18:01 -0400
361 sipb-xen-database (10.4) unstable; urgency=low
363 * Ubuntu's dch sucks.
365 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Fri, 28 Mar 2008 20:43:42 -0400
367 sipb-xen-database (10.3ubuntu1) gutsy; urgency=low
369 * Expose a function for clearing the cache.
371 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 28 Mar 2008 20:31:06 -0400
373 sipb-xen-database (10.3) unstable; urgency=low
375 * Use 'acl', not 'users', for the reference to the machine_access table.
377 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Thu, 24 Jan 2008 17:23:33 -0500
379 sipb-xen-database (10.2) unstable; urgency=low
381 * Add MachineAccess to __all__ so it can be imported
382 * Remove unnecessary constructors for database objects
384 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Mon, 12 Nov 2007 04:53:47 -0500
386 sipb-xen-database (10.1) unstable; urgency=low
388 * Make sipb-xen-database-tables safer (don't default to drop_all)
390 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Mon, 12 Nov 2007 04:39:59 -0500
392 sipb-xen-database (10) unstable; urgency=low
394 * Added a machine_access table for cached ACLs
396 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Mon, 12 Nov 2007 04:24:35 -0500
398 sipb-xen-database (9.0) unstable; urgency=low
402 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Wed, 10 Oct 2007 00:17:20 -0400
404 sipb-xen-database (9) unstable; urgency=low
406 * Add administrator column and backrefs to machine.
408 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Wed, 10 Oct 2007 00:11:47 -0400
410 sipb-xen-database (8) gutsy; urgency=low
412 * Prepend d_ to database VMs.
414 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Tue, 9 Oct 2007 02:35:51 -0400
416 sipb-xen-database (7.00002) gutsy; urgency=low
418 * Actually import re.
420 -- Anders Kaseorg <andersk@mit.edu> Sun, 07 Oct 2007 04:34:07 -0400
422 sipb-xen-database (7.00001) gutsy; urgency=low
426 -- Anders Kaseorg <andersk@mit.edu> Sun, 07 Oct 2007 03:40:25 -0400
428 sipb-xen-database (7) unstable; urgency=low
430 * nics primary key should be mac address, not hostname.
431 * Make ip unique, and constructor for nics.
432 * Add a table for boot CDs.
433 * Add cdrom_image parameter.
434 * Regex sanity checking.
436 -- Anders Kaseorg <andersk@mit.edu> Sun, 07 Oct 2007 03:18:30 -0400
438 sipb-xen-database (6) unstable; urgency=low
440 * Adding a script to create lvm volumes
442 -- Nelson Elhage <nelhage@mit.edu> Sat, 22 Sep 2007 13:59:36 -0400
444 sipb-xen-database (5) unstable; urgency=low
446 * Change the host from sipb-vm-1 to sipb-xen-dev
448 -- Nelson Elhage <nelhage@mit.edu> Sat, 8 Sep 2007 16:16:07 -0400
450 sipb-xen-database (4) unstable; urgency=low
452 * Add script=vif-sipbroute to our vif lines
454 -- Nelson Elhage <nelhage@mit.edu> Fri, 24 Aug 2007 22:07:18 -0400
456 sipb-xen-database (3) unstable; urgency=low
458 * Add a connect() line to sipb-database
459 * Fix some other bugs in sipb-database
461 -- Nelson Elhage <nelhage@mit.edu> Sun, 19 Aug 2007 19:40:08 -0400
463 sipb-xen-database (2) unstable; urgency=low
465 * Fix the postinit and prerm scripts to create a sipb-xen user
467 -- Nelson Elhage <nelhage@mit.edu> Thu, 16 Aug 2007 16:27:36 -0400
469 sipb-xen-database (1) unstable; urgency=low
473 -- Nelson Elhage <nelhage@mit.edu> Sun, 15 Jul 2007 16:01:16 -0400