1 invirt-database (0.1.8) unstable; urgency=low
4 * Added Record superclass for models, handling __repr__ consistently.
7 invirt.database.record, .owner:
8 * use self.c rather than self.__dict__ for SQLAlchemy fields
9 * make Record._ignore, Owner.get* classmethods
10 * fold FormattableRecord, NullableRecord into Record
11 * shorten types in lists to __name__
14 * refactor code that sets values
15 * print full help on no arguments
17 -- Greg Price <price@mit.edu> Thu, 26 Feb 2009 22:51:43 -0500
19 invirt-database (0.1.7) unstable; urgency=low
21 * Disk quotas are measured in gibibytes.
22 * Rename invirt-setquotas to invirt-quota.
23 * Be explicit about units in invirt-quota.
25 -- Evan Broder <broder@mit.edu> Tue, 17 Feb 2009 04:29:20 -0500
27 invirt-database (0.1.6) unstable; urgency=low
29 * Move invirt-setquotas into this package.
30 * Don't explicitly initialize the values for each quota when creating a
33 -- Evan Broder <broder@mit.edu> Tue, 17 Feb 2009 03:44:20 -0500
35 invirt-database (0.1.5) unstable; urgency=low
37 * Make the default values on the owners table explicit
38 (Note: This is a NOOP, since a nullable field with no otherwise
39 specified default defaults to NULL)
41 -- Evan Broder <broder@mit.edu> Tue, 17 Feb 2009 03:36:47 -0500
43 invirt-database (0.1.4) unstable; urgency=low
47 -- Peter A. Iannucci <iannucci@mit.edu> Tue, 17 Feb 2009 02:59:14 -0500
49 invirt-database (0.1.3) unstable; urgency=low
51 * Added owner table to database with ram, disk, and VM quotas
52 * Refactored Owner class into separate sourcefile
54 -- Peter A. Iannucci <iannucci@mit.edu> Tue, 17 Feb 2009 01:31:53 -0500
56 invirt-database (0.1.2) unstable; urgency=low
58 * Clean up the .egg-info directory from the right place.
60 -- Evan Broder <broder@mit.edu> Mon, 05 Jan 2009 23:50:47 -0500
62 invirt-database (0.1.1) unstable; urgency=low
64 * Correct a lintian spelling warning.
66 -- Evan Broder <broder@mit.edu> Mon, 05 Jan 2009 23:40:44 -0500
68 invirt-database (0.1.0) unstable; urgency=low
70 * Turn on lazy loading for all tables
72 -- Evan Broder <broder@mit.edu> Mon, 17 Nov 2008 21:57:35 -0500
74 invirt-database (0.0.6) unstable; urgency=low
76 * Let machines.administrator be NULL
78 -- Evan Broder <broder@mit.edu> Mon, 17 Nov 2008 13:41:48 -0500
80 invirt-database (0.0.5) unstable; urgency=low
82 * Add an architecture field to the autoinstaller table
84 -- Evan Broder <broder@mit.edu> Mon, 17 Nov 2008 12:18:02 -0500
86 invirt-database (0.0.3) unstable; urgency=low
88 * Add attributes to the ORM objects to connect mirrors and cdroms
90 -- Evan Broder <broder@mit.edu> Tue, 28 Oct 2008 03:16:18 -0400
92 invirt-database (0.0.2) unstable; urgency=low
94 * Export mirrors_table and Mirrors from invirt.database.models
96 -- Evan Broder <broder@mit.edu> Tue, 28 Oct 2008 03:04:54 -0400
98 invirt-database (0.0.1) unstable; urgency=low
100 * sipb-xen-database-common -> invirt-database
101 * sipb-xen-database-server -> invirt-database-server (a separate source package)
102 * sipb-xen-database-client -> invirt-xen-config
104 -- Evan Broder <broder@mit.edu> Sat, 25 Oct 2008 19:22:46 -0400
106 sipb-xen-database (10.36.1) unstable; urgency=low
108 * Typo in the new tables
110 -- Evan Broder <broder@mit.edu> Sat, 25 Oct 2008 15:01:47 -0400
112 sipb-xen-database (10.36) unstable; urgency=low
114 * Kill the remnants of the sipb_xen_database package
115 * Add the CDROM mirrors table
117 -- Evan Broder <broder@mit.edu> Sat, 25 Oct 2008 14:48:32 -0400
119 sipb-xen-database (10.35) unstable; urgency=low
121 * Shorten initscript with spiffy new library from sipb-xen-base
123 -- Greg Price <price@mit.edu> Fri, 24 Oct 2008 07:25:56 -0400
125 sipb-xen-database (10.34) unstable; urgency=low
127 * yet another new-sqlalchemy fix, this one post-0.4.2
129 -- Greg Price <price@mit.edu> Thu, 23 Oct 2008 23:02:46 -0400
131 sipb-xen-database (10.33) unstable; urgency=low
133 * Catch calls to restart Postgres and translate them into a sequential
136 -- Evan Broder <broder@mit.edu> Mon, 20 Oct 2008 13:05:29 -0400
138 sipb-xen-database (10.32) unstable; urgency=low
140 * invirt.database.clear_cache should actually do something
142 -- Evan Broder <broder@mit.edu> Sun, 19 Oct 2008 02:02:37 -0400
144 sipb-xen-database (10.31) unstable; urgency=low
146 * Database-managed VMs should never even think about bridging
148 -- Evan Broder <broder@mit.edu> Sun, 19 Oct 2008 01:46:45 -0400
150 sipb-xen-database (10.30.4) unstable; urgency=low
152 * Fix a typo in the CDROM image path
154 -- Evan Broder <broder@mit.edu> Wed, 15 Oct 2008 13:21:10 -0400
156 sipb-xen-database (10.30.3) unstable; urgency=low
158 * fix copy-paste errors in initscript: this is database, not console
159 * fix "typo" in initscript for package name printed in logs
161 -- Greg Price <price@mit.edu> Sat, 11 Oct 2008 17:50:11 -0700
163 sipb-xen-database (10.30.2) unstable; urgency=low
165 * Fix a typo in the CDROM lookup in sipb-database
167 -- Evan Broder <broder@mit.edu> Sat, 11 Oct 2008 19:17:05 -0400
169 sipb-xen-database (10.30.1) unstable; urgency=low
171 * Don't strip quotes that won't be there
173 -- Evan Broder <broder@mit.edu> Fri, 10 Oct 2008 01:48:48 -0400
175 sipb-xen-database (10.30) unstable; urgency=low
177 * Look for CD images in /dev/xenvg/image_* and validate image name from
179 * Pass the installer arguments unaltered to the kernel, matching the
182 -- Evan Broder <broder@mit.edu> Thu, 09 Oct 2008 02:09:42 -0400
184 sipb-xen-database (10.29) unstable; urgency=low
186 * Some fixes in the sipb-database script
188 -- Evan Broder <broder@mit.edu> Mon, 06 Oct 2008 18:55:24 -0400
190 sipb-xen-database (10.28) unstable; urgency=low
192 * Re-establish the database connection if the server goes AWOL
194 -- Evan Broder <broder@mit.edu> Sat, 04 Oct 2008 23:19:59 -0400
196 sipb-xen-database (10.27) unstable; urgency=low
198 * Update sipb-database to work with newer SQLAlchemy and Xen
200 -- Evan Broder <broder@mit.edu> Fri, 03 Oct 2008 20:08:16 -0400
202 sipb-xen-database (10.26.1) unstable; urgency=low
204 * We want autoflush off, too
206 -- Evan Broder <broder@mit.edu> Fri, 03 Oct 2008 19:22:12 -0400
208 sipb-xen-database (10.26) unstable; urgency=low
210 * Disable transactions by default
212 -- Evan Broder <broder@mit.edu> Thu, 02 Oct 2008 19:40:34 -0400
214 sipb-xen-database (10.25) unstable; urgency=low
216 * add remote and console to pg_hba.conf template
217 * fix init script so it works
218 * port more code to sqlalchemy 0.4
220 -- Greg Price <price@mit.edu> Wed, 01 Oct 2008 19:30:26 -0400
222 sipb-xen-database (10.24) unstable; urgency=low
224 * Update postgresql.conf for Hardy
226 -- Evan Broder <broder@mit.edu> Wed, 01 Oct 2008 03:12:36 -0400
228 sipb-xen-database (10.23) unstable; urgency=low
230 * switch to postgresql 8.3, as 8.1 isn't in hardy
232 -- Greg Price <price@mit.edu> Wed, 01 Oct 2008 02:09:43 -0400
234 sipb-xen-database (10.22) unstable; urgency=low
236 * depend on postgresql without specifying old version 8.1
238 -- Greg Price <price@mit.edu> Wed, 01 Oct 2008 01:55:49 -0400
240 sipb-xen-database (10.21) unstable; urgency=low
244 -- Greg Price <price@mit.edu> Tue, 30 Sep 2008 23:50:25 -0400
246 sipb-xen-database (10.20) hardy; urgency=low
248 * port to sqlalchemy-0.4, which cuts out some newly deprecated
249 interfaces and allowed some still-present interfaces to bitrot
251 -- Greg Price <price@mit.edu> Mon, 29 Sep 2008 06:06:21 +0000
253 sipb-xen-database (10.19) unstable; urgency=low
255 * Generate config files for pg_hba.conf
256 * replace postgresql.conf
258 -- Sam Hartman <hartmans@xvm.mit.edu> Mon, 25 Aug 2008 00:38:21 +0000
260 sipb-xen-database (10.18) unstable; urgency=low
262 * add 'adminable' column to machines; for selectively, temporarily,
263 enabling admin mode on a machine
265 -- Greg Price <price@mit.edu> Wed, 6 Aug 2008 01:02:59 -0400
267 sipb-xen-database (10.17) unstable; urgency=low
269 * pull IP gateway, network from config
270 * configurabilization complete!
272 -- Greg Price <price@mit.edu> Sun, 3 Aug 2008 01:16:53 -0400
274 sipb-xen-database (10.16) unstable; urgency=low
276 in sipb-xen-database-tables:
277 * use invirt.database, and take default db uri
279 -- Greg Price <price@mit.edu> Sun, 3 Aug 2008 00:51:32 -0400
281 sipb-xen-database (10.15) unstable; urgency=low
283 in /etc/xen/database:
284 * uncommitted changes on black-mesa
285 * sipb_xen_database -> invirt.database
289 * get default db uri from invirt.config
291 -- Greg Price <price@mit.edu> Sun, 3 Aug 2008 00:26:46 -0400
293 sipb-xen-database (10.14) unstable; urgency=low
295 * Rename sipb_xen_database -> invirt.database,
296 keeping old name too for now, for compatibility.
298 -- Greg Price <price@mit.edu> Sat, 2 Aug 2008 23:19:18 -0400
300 sipb-xen-database (10.13) unstable; urgency=low
302 * Modify autoinstalls table to specify distribution/mirror.
304 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Sat, 21 Jun 2008 21:25:21 -0400
306 sipb-xen-database (10.12) unstable; urgency=low
308 * Add a description field.
310 -- Anders Kaseorg <andersk@mit.edu> Wed, 18 Jun 2008 03:52:49 -0400
312 sipb-xen-database (10.11) unstable; urgency=low
314 * Specify ON DELETE CASCADE
316 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 06 Jun 2008 12:25:35 -0400
318 sipb-xen-database (10.10) unstable; urgency=low
320 * Make machine.acl a private relation.
322 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 06 Jun 2008 12:03:09 -0400
324 sipb-xen-database (10.9) unstable; urgency=low
326 * Eager loading of relations for better performance.
328 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Mon, 02 Jun 2008 01:39:11 -0400
330 sipb-xen-database (10.8) unstable; urgency=low
332 * Configure serial console on boot
334 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Thu, 1 May 2008 20:21:25 -0400
336 sipb-xen-database (10.7) unstable; urgency=low
338 * Depend on psql client in -client package.
340 -- Greg Price <price@mit.edu> Sat, 26 Apr 2008 21:06:41 -0400
342 sipb-xen-database (10.6) unstable; urgency=low
344 * Support autoinstalls table.
346 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Mon, 21 Apr 2008 22:34:46 -0400
348 sipb-xen-database (10.5) unstable; urgency=low
350 * Enable USB tablet device in guests.
352 -- Anders Kaseorg <andersk@mit.edu> Mon, 21 Apr 2008 17:39:59 -0400
354 sipb-xen-database (10.4.1) unstable; urgency=low
356 * Actually export the cache clearing function.
358 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 28 Mar 2008 21:18:01 -0400
360 sipb-xen-database (10.4) unstable; urgency=low
362 * Ubuntu's dch sucks.
364 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Fri, 28 Mar 2008 20:43:42 -0400
366 sipb-xen-database (10.3ubuntu1) gutsy; urgency=low
368 * Expose a function for clearing the cache.
370 -- Eric Price <ecprice@pseudomyrmex.mit.edu> Fri, 28 Mar 2008 20:31:06 -0400
372 sipb-xen-database (10.3) unstable; urgency=low
374 * Use 'acl', not 'users', for the reference to the machine_access table.
376 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Thu, 24 Jan 2008 17:23:33 -0500
378 sipb-xen-database (10.2) unstable; urgency=low
380 * Add MachineAccess to __all__ so it can be imported
381 * Remove unnecessary constructors for database objects
383 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Mon, 12 Nov 2007 04:53:47 -0500
385 sipb-xen-database (10.1) unstable; urgency=low
387 * Make sipb-xen-database-tables safer (don't default to drop_all)
389 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Mon, 12 Nov 2007 04:39:59 -0500
391 sipb-xen-database (10) unstable; urgency=low
393 * Added a machine_access table for cached ACLs
395 -- Quentin Smith <quentin@sipb-xen-dev.mit.edu> Mon, 12 Nov 2007 04:24:35 -0500
397 sipb-xen-database (9.0) unstable; urgency=low
401 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Wed, 10 Oct 2007 00:17:20 -0400
403 sipb-xen-database (9) unstable; urgency=low
405 * Add administrator column and backrefs to machine.
407 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Wed, 10 Oct 2007 00:11:47 -0400
409 sipb-xen-database (8) gutsy; urgency=low
411 * Prepend d_ to database VMs.
413 -- Eric Price <ecprice@sipb-xen-dev.mit.edu> Tue, 9 Oct 2007 02:35:51 -0400
415 sipb-xen-database (7.00002) gutsy; urgency=low
417 * Actually import re.
419 -- Anders Kaseorg <andersk@mit.edu> Sun, 07 Oct 2007 04:34:07 -0400
421 sipb-xen-database (7.00001) gutsy; urgency=low
425 -- Anders Kaseorg <andersk@mit.edu> Sun, 07 Oct 2007 03:40:25 -0400
427 sipb-xen-database (7) unstable; urgency=low
429 * nics primary key should be mac address, not hostname.
430 * Make ip unique, and constructor for nics.
431 * Add a table for boot CDs.
432 * Add cdrom_image parameter.
433 * Regex sanity checking.
435 -- Anders Kaseorg <andersk@mit.edu> Sun, 07 Oct 2007 03:18:30 -0400
437 sipb-xen-database (6) unstable; urgency=low
439 * Adding a script to create lvm volumes
441 -- Nelson Elhage <nelhage@mit.edu> Sat, 22 Sep 2007 13:59:36 -0400
443 sipb-xen-database (5) unstable; urgency=low
445 * Change the host from sipb-vm-1 to sipb-xen-dev
447 -- Nelson Elhage <nelhage@mit.edu> Sat, 8 Sep 2007 16:16:07 -0400
449 sipb-xen-database (4) unstable; urgency=low
451 * Add script=vif-sipbroute to our vif lines
453 -- Nelson Elhage <nelhage@mit.edu> Fri, 24 Aug 2007 22:07:18 -0400
455 sipb-xen-database (3) unstable; urgency=low
457 * Add a connect() line to sipb-database
458 * Fix some other bugs in sipb-database
460 -- Nelson Elhage <nelhage@mit.edu> Sun, 19 Aug 2007 19:40:08 -0400
462 sipb-xen-database (2) unstable; urgency=low
464 * Fix the postinit and prerm scripts to create a sipb-xen user
466 -- Nelson Elhage <nelhage@mit.edu> Thu, 16 Aug 2007 16:27:36 -0400
468 sipb-xen-database (1) unstable; urgency=low
472 -- Nelson Elhage <nelhage@mit.edu> Sun, 15 Jul 2007 16:01:16 -0400