8 if ! getent passwd repository >/dev/null 2>&1; then
9 adduser --system repository
11 if ! getent group repo >/dev/null 2>&1; then
12 addgroup --system repo
15 if ! getent passwd git >/dev/null 2>&1; then
16 adduser --system --home /srv/git --shell /usr/bin/git-shell git
19 if ! [ -d /srv/git ]; then
23 cat >>/etc/sudoers <<EOF
25 %repo ALL=(repository) ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
30 echo "invirt-dev: run"
31 echo " adduser --disabled-password \$user"
32 echo " adduser \$user repo"
33 echo " adduser \$user sbuild"
34 echo "to make individual users that will build packages."
38 abort-upgrade|abort-remove|abort-deconfigure)
42 echo "postinst called with unknown argument \`$1'" >&2
47 if [ -x /etc/init.d/invirt-dev ]; then
48 if hash invoke-rc.d 2>/dev/null; then
49 invoke-rc.d invirt-dev start
51 /etc/init.d/invirt-dev start