8 if ! getent passwd repository >/dev/null 2>&1; then
9 adduser --system repository
11 if ! getent group repo >/dev/null 2>&1; then
12 addgroup --system repo
15 if ! getent passwd git >/dev/null 2>&1; then
16 adduser --system --home /srv/git --shell /usr/bin/git-shell git
21 cat >>/etc/sudoers <<EOF
23 %repo ALL=(repository) ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
27 echo "invirt-dev: run"
28 echo " adduser --disabled-password \$user"
29 echo " adduser \$user repo"
30 echo " adduser \$user sbuild"
31 echo "to make individual users that will build packages."
35 abort-upgrade|abort-remove|abort-deconfigure)
39 echo "postinst called with unknown argument \`$1'" >&2