Update the Invirt git configuration at install-time.
[invirt/packages/invirt-dev.git] / debian / invirt-dev.postinst
1 #!/bin/sh
2 set -e
3
4 #DEBHELPER#
5
6 case "$1" in
7     configure)
8         if ! getent passwd repository >/dev/null 2>&1; then
9             adduser --system repository
10         fi
11         if ! getent group repo >/dev/null 2>&1; then
12             addgroup --system repo
13         fi
14
15         if ! getent passwd git >/dev/null 2>&1; then
16             adduser --system --home /srv/git --shell /usr/bin/git-shell git
17         fi
18
19         invirt-build-conf
20             
21         cat >>/etc/sudoers <<EOF
22 ### BEGIN invirt-dev
23 %repo   ALL=(repository)        ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
24 ### END invirt-dev
25 EOF
26         echo "-----"
27         echo "invirt-dev: run"
28         echo "  adduser --disabled-password \$user"
29         echo "  adduser \$user repo"
30         echo "  adduser \$user sbuild"
31         echo "to make individual users that will build packages."
32         echo "-----"
33     ;;
34
35     abort-upgrade|abort-remove|abort-deconfigure)
36     ;;
37
38     *)
39         echo "postinst called with unknown argument \`$1'" >&2
40         exit 1
41     ;;
42 esac