8 if ! getent passwd repository >/dev/null 2>&1; then
9 adduser --system repository
11 if ! getent group repo >/dev/null 2>&1; then
12 addgroup --system repo
15 cat >>/etc/sudoers <<EOF
17 %repo ALL=(repository) ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
21 echo "invirt-dev: run"
22 echo " adduser --disabled-password \$user"
23 echo " adduser \$user repo"
24 echo " adduser \$user sbuild"
25 echo "to make individual users that will build packages."
29 abort-upgrade|abort-remove|abort-deconfigure)
33 echo "postinst called with unknown argument \`$1'" >&2