8 if ! getent passwd repository >/dev/null 2>&1; then
9 adduser --system repository
11 if ! getent group repo >/dev/null 2>&1; then
12 addgroup --system repo
15 if ! getent passwd git >/dev/null 2>&1; then
16 adduser --system --home /srv/git --shell /usr/bin/git-shell git
19 if ! [ -d /srv/git ]; then
25 cat >>/etc/sudoers <<EOF
27 %repo ALL=(repository) ALWAYS_SET_HOME,NOPASSWD: /usr/bin/reprepro
31 echo "invirt-dev: run"
32 echo " adduser --disabled-password \$user"
33 echo " adduser \$user repo"
34 echo " adduser \$user sbuild"
35 echo "to make individual users that will build packages."
39 abort-upgrade|abort-remove|abort-deconfigure)
43 echo "postinst called with unknown argument \`$1'" >&2