3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
23 configure: configure-stamp
26 # Add here commands to configure the package.
33 build-stamp: configure-stamp
36 # Add here commands to compile the package.
44 rm -f build-stamp configure-stamp
46 # Add here commands to clean up after the build process.
57 # Add here commands to install the package into debian/sipb-xen-dev.
61 # Build architecture-independent files here.
62 binary-arch: build install
63 # We have nothing to do by default.
65 # Build architecture-dependent files here.
66 binary-indep: build install
96 binary: binary-indep binary-arch
97 .PHONY: build clean binary-indep binary-arch binary install configure