Updating version for precise
[invirt/packages/invirt-kerberos-config.git] / debian / rules
index b4c1c2c..fb88cc4 100755 (executable)
@@ -1,28 +1,4 @@
 #!/usr/bin/make -f
 
-DEB_DIVERT_EXTENSION = .invirt
-DEB_CHECK_FILES_SOURCE_/etc/krb5.conf.invirt = \
-        /usr/share/kerberos-configs/krb5.conf.template
-DEB_DIVERT_FILES_invirt-kerberos-config += \
-        /etc/krb5.conf.invirt
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/rules/config-package.mk
-
-common-build-indep:: debian/krb5.conf.invirt.mako
-
-# A normal kerberos-config package would just create an
-# /etc/krb5.conf.invirt file (probably using the DEB_TRANSFORM_FILES
-# syntactic sugar, instead of calling the transform script directly).
-# However, we want to generate that file dynamically, based on the realm
-# setting in /etc/master/invirt.yaml. So, instead of packaging
-# krb5.conf.invirt, we build a mako template in
-# /etc/krb5.conf.invirt.mako, and our initscript renders it to
-# /etc/krb5.conf.invirt. In order to get the mako template right, we
-# generate it by transforming the base krb5.conf to add a mako template
-# tags specifying the default realm.
-debian/krb5.conf.invirt.mako: $(call debian_check_files,/etc/krb5.conf)
-       debian/transform_krb5.conf.invirt.mako < $< > $@
-
-clean::
-       rm -f debian/krb5.conf.invirt.mako
+%:
+       dh $@ --with=config-package