+ mkdir -p /etc/invirt/secrets
+ if ! [ -e /etc/invirt/secrets/vnc.pem ]; then
+ openssl genrsa -out /etc/invirt/secrets/vnc.pem 1024 >/dev/null
+ fi
+
+ if ! [ -e /etc/invirt/secrets/vnc.crt ]; then
+ openssl req -new -x509 -nodes -sha1 -subj '/' -key /etc/invirt/secrets/vnc.pem \
+ > /etc/invirt/secrets/vnc.crt
+ fi
+
+ if ! [ -e /etc/invirt/secrets/vnc-key ]; then
+ openssl rand -base64 33 >/etc/invirt/secrets/vnc-key
+ fi