Depend on python-cherrypy3 and python-mako in preparation of migrating the web site
[invirt/packages/invirt-web.git] / debian / invirt-web.postinst
1 #!/bin/sh
2 # postinst script for #PACKAGE#
3 #
4 # see: dh_installdeb(1)
5
6 set -e
7
8 # summary of how this script can be called:
9 #        * <postinst> `configure' <most-recently-configured-version>
10 #        * <old-postinst> `abort-upgrade' <new version>
11 #        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12 #          <new-version>
13 #        * <postinst> `abort-remove'
14 #        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15 #          <failed-install-package> <version> `removing'
16 #          <conflicting-package> <version>
17 # for details, see http://www.debian.org/doc/debian-policy/ or
18 # the debian-policy package
19
20
21 case "$1" in
22     configure)
23         cd /var/www/invirt-web
24         make clean && make all
25         chgrp -R invirt .
26         chmod -R g+w .
27
28         a2enmod rewrite
29         a2enmod ssl
30         a2enmod auth_sslcert
31         
32         # Our init script proxies all requests to Apache's, so Apache's
33         # running is just a NOP
34         update-rc.d -f apache2 remove
35     ;;
36
37     abort-upgrade|abort-remove|abort-deconfigure)
38     ;;
39
40     *)
41         echo "postinst called with unknown argument \`$1'" >&2
42         exit 1
43     ;;
44 esac
45
46 # dh_installdeb will replace this with shell code automatically
47 # generated by other debhelper scripts.
48
49 #DEBHELPER#
50
51 exit 0
52
53